Project

General

Profile

Emulator Issues #10827

PoP Sands of Time Unknown Opcode error before end credits

Added by xerxes almost 2 years ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Prince of Persia: the Sands of Time

Game ID?

GPTE41 (v1.00)

MD5 Hash?

df7cd3837909dc41dd0a6b1821466d56 (confirmed with redump)

What's the problem? Describe what went wrong.

During the transition from the cutscene after the final boss to the credits, Dolphin will throw the following errors:

https://i.gyazo.com/ab80eab136155e7d6da6a2fea6282f00.png
https://i.gyazo.com/59671ef0ee0ef24d37c88aa1a81f1419.png
https://i.gyazo.com/51eb02a4ef3ec865b163cf356f5aeae2.png
https://i.gyazo.com/48b2c69599f9224415a92ec5b10ad79e.png
https://i.gyazo.com/9490c3ae0b6aae21673f59e1e0de4b21.png

The last couple cycle a few times, but after mashing Yes and OK enough, the credits will play seemingly without problems.

What steps will reproduce the problem?

Load the attached save on the final boss, kill the boss (press B a lot, then press A to dodge when he winds up to attack), then watch the cutscene that plays. You should naturally land on the errors without having to do anything else after the cutscene finishes.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes, 5.0-6229

Is the issue present in the latest stable version?

Yes, it still gives an unknown opcode in 5.0, but it doesn't also give the shader error afterwards.

What are your PC specifications?

Intel Core i3-3220 @ 3.3GHz, NVIDIA GeForce GTX 1060 6GB, Windows 10

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

I attached a save that's immediately on the final boss.

41-GPTE-Prince of Persia.gci (120 KB) 41-GPTE-Prince of Persia.gci xerxes, 01/24/2018 11:08 PM

Related issues

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by JMC4789 almost 2 years ago

Does it happen in single core?

#2 Updated by xerxes almost 2 years ago

No, it doesn't. I guess it's another dual core issue.

#3 Updated by JMC4789 over 1 year ago

  • Status changed from New to Duplicate

#4 Updated by JMC4789 over 1 year ago

Also available in: Atom PDF