Project

General

Profile

Emulator Issues #10828

PoP Sands of Time input delay on overwrite save dialogue

Added by xerxes over 1 year ago. Updated 5 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Prince of Persia: the Sands of Time

Game ID?

GPTE41 (v1.00)

MD5 Hash?

df7cd3837909dc41dd0a6b1821466d56 (confirmed with redump)

What's the problem? Describe what went wrong.

When on the overwrite save dialogue, input becomes extremely delayed and unresponsive. It will seem like it's not taking any inputs, and then it'll freak out and start flipping between Yes and No rapidly.

What steps will reproduce the problem?

Load the save I attached from issue 10827 on the 10% completion file, and walk back into the shining light on the ground immediately next to where you load in. Choose to save, and save over the 10% save again. Try pressing up/down on the dialogue that appears asking you to confirm the save overwrite, and see the input delay.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes, 5.0-6229

Is the issue present in the latest stable version?

Yes, it happens in 5.0 as well

What are your PC specifications?

Intel Core i3-3220 @ 3.3GHz, NVIDIA GeForce GTX 1060 6GB, Windows 10

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

There's an attached save at issue 10827 which can be used for this issue as well.


Related issues

Is duplicate of Emulator - Emulator Issues #7481: Emulate Proper Memory Card timingsFixed

History

#1 Updated by JMC4789 over 1 year ago

What's the framerate at? our EXI timings are wrong, so, sometimes when attempting to check the memory card the internal framerate will drop a lot.

#2 Updated by xerxes over 1 year ago

It sticks around 12FPS when normally it runs at 30FPS, so that could be linked to it. But the screen where you choose the save to overwrite right before the confirmation dialogue also runs at 12FPS and doesn't have the noticeably terrible input delay.

#3 Updated by JMC4789 over 1 year ago

  • Status changed from New to Duplicate

This is accepted but I think I want to roll it in with another issue.

#4 Updated by JMC4789 over 1 year ago

#5 Updated by xerxes 5 months ago

This still happens as of 5.0-9795.

Also available in: Atom PDF