Project

General

Profile

Emulator Issues #10837

PoP Warrior Within blocky particle effects

Added by xerxes over 1 year ago. Updated 12 months ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Prince of Persia: Warrior Within

Game ID?

G2OE41

MD5 Hash?

dce5a1a75982905554d9d465a743ff3b (confirmed with redump)

What's the problem? Describe what went wrong.

There's a point while trying to get back from activating the first tower where all the particle effects in the game break. This is visible on flames, blood splats, and the smokey effect around one of the black miniboss enemies. No settings seem to affect this. After further progressing in the game, the effects return to normal, even if you come back to the same spot.

What steps will reproduce the problem?

I attached a save that's as close as possible, so bear with me a little bit. Load the second file that's labeled "The Second Tower". You'll be at the edge of a death pit next to a fountain. Run up the wall next to the fountain to get to the ledge above, but don't go forward; do a 180 instead and wall run to the platform in the corner, and again past the saws. Go out on the balcony, ignore the two enemies, and instead go to your left and wall run past more saws. Maneuver down the ladder and ledges to two more enemies, and lure them down the hall behind them to a ladder. Kill both of them, then jump from the ladder to the lever to open the door, and continue forward to two more enemies.

This is where you want to be. Kill or skip these two enemies and grab the outside edge of the balcony you're standing on, and jump to the poles. Pay very close attention to the flames way down on the ground below you. They will be displaying properly as you jump to the first pole, and from that to the second, but as soon as you make the last jump from the second pole to the opposing balcony, the flame effects on the ground will break. For an up close look, attack the two enemies after the poles and see their blood display as giant red blocks.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes, 5.0-6243

Is the issue present in the latest stable version?

Yes, it happens in 5.0

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

Fifolog was too big, cannot attach. (Am I doing something wrong here?)

What are your PC specifications?

Intel Core i3-3220 @ 3.3GHz, NVIDIA GeForce GTX 1060 6GB, Windows 10

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

Here's a screenshot of what the blood in particular looks like, since it's really apparent that's not supposed to happen: https://i.gyazo.com/c43a15e265252105731632e33c95dad3.png

41-G2OE-Prince of Persia__3a__ WW.gci (168 KB) 41-G2OE-Prince of Persia__3a__ WW.gci xerxes, 01/28/2018 04:38 AM
popww-blood4.7z (1.74 MB) popww-blood4.7z xerxes, 01/28/2018 05:26 AM

History

#1 Updated by JMC4789 over 1 year ago

Try turning off dualcore.

#2 Updated by xerxes over 1 year ago

Yes, it happens in single core. I just tried it again.

#3 Updated by JMC4789 over 1 year ago

Try recording a fifolog that's ~2 frames long and compressing it with zip/7z

Also try stuff in the GPU settings tab, like EFB Copies, EFB Access, etc. You may need to do this /before/ you enter the room if it loads the effects earlier.

#4 Updated by xerxes over 1 year ago

Right, file compression, that's a thing. I knew that. Here's a 4 frame fifolog.

I tried flipping all the settings in graphics hacks to opposite of default and different video backends and it still happens.

#5 Updated by JMC4789 over 1 year ago

Tried the software renderer? Will be painful, but worth knowing. It could be a texture cache issue too. May be worth trying some older builds.

#6 Updated by JMC4789 over 1 year ago

Check disable fog and see if that helps. It fixes the fifolog here.

#7 Updated by xerxes over 1 year ago

Sure. Should I keep going with software renderer first? I did the math and it's going to take me at least an hour to get to the spot again...

#8 Updated by xerxes over 1 year ago

Yes, it happens in software renderer. I had an unknown opcode happen in the process, but I managed to make it to the guys and attack them and had the same blocky blood.

https://i.gyazo.com/d492a766289163eefc3eae41738274a2.png
https://i.gyazo.com/0c5e10544d82154abea7b24ab5270531.png

And yes, disable fog seems to solve the issue entirely. I don't even see any missing effects or anything using it either.

#9 Updated by JMC4789 over 1 year ago

  • Status changed from New to Accepted

So we have a flaw in our fog emulation. Hopefully Stenzek will look at it later.

#10 Updated by JMC4789 over 1 year ago

Can you get a screenshot from console for comparison as we try to fix this?

#11 Updated by xerxes over 1 year ago

I'd like to, but I don't have a working capture card. Normally I use publicly available longplay/let's play footage for reports, but the only longplay for the GameCube release of this game is for the PAL version, and he runs through the segment in the fifolog without attacking anything anyways: https://www.youtube.com/watch?v=6DZ4IH_mIS4&t=11956 (3:19:40 or so). You can see the edge of the skybox and the smoke enemy in the background rendered properly in that footage though (they both look red with fog on in Dolphin)

#12 Updated by JMC4789 over 1 year ago

  • Status changed from Accepted to Fix pending

I bought a TMNT game on the same engine and verified.

Fixed in PR6348 - https://github.com/dolphin-emu/dolphin/pull/6348

#13 Updated by JMC4789 12 months ago

  • Status changed from Fix pending to Fixed

This actually got fixed and I forgot to close the issue. Whoops.

Also available in: Atom PDF