Project

General

Profile

Emulator Issues #10876

Feature Request - Handle Demo GameID to GameINI mapping

Added by kolano over 2 years ago. Updated almost 2 years ago.

Status:
Won't fix
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Feature request
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

The GameIDs of demo titles should map to their base INIs. For instance "Pro Evolution Soccer 2008" is RWEPA4 and it's demo is DWEPA4. So DWEPA4 should map to the RWE.ini.

Demo GameIDs are typically prefixed with "D" (for GameCube / Wii) or "X" for WiiWare, and should generally be mapped to the INI with matching characters beyond the first. It's possible for there to be overlapped mappings for Wii titles due to using both "R" and "S" prefixes, but there are few demo releases so hopefully it won't occur.

A few titles don't line up for instance...

DASE4Q = Disney Epic Mickey (Demo)
DAXE01 = The Legend of Zelda: Skyward Sword (Demo)

...but most seem to.

History

#1 Updated by JosJuice over 2 years ago

  • Issue type changed from Bug to Feature request
  • Status changed from New to Questionable

I don't think it would be better to implement this than just creating demo game INIs manually, especially since the IDs don't match up 100% of the time.

#2 Updated by JMC4789 almost 2 years ago

  • Status changed from Questionable to Won't fix

I'm going to go the same direction as JosJuice but further - this definitely isn't consistent and I don't think we should try for a half-working heuristic. We'll have to slowly map it out ourselves.

Also available in: Atom PDF