Project

General

Profile

Emulator Issues #10877

RE0 Single-core broken

Added by Tommy78 almost 2 years ago. Updated about 1 year ago.

Status:
Accepted
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Current
Regression:
Yes
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
5.0-2462
Fixed in:

Description

Game Name?

Resident Evil 0 (NTSC) (Disc1)

Game ID? (right click the game in the game list, properties, info tab)

GBZE08

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

It's a good dump.

What's the problem? Describe what went wrong.

Load the game with single-core and dolphin will crash. Load the game with dual-core and the game works normally.

What steps will reproduce the problem?

Start the game in single-core. Otherwise stock settings.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Latest Android Development Build as of now (5.0-6307).

Is the issue present in the latest stable version?

There is no stable Android version.

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

[First broken version number here (if applicable)]

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

[Attach any fifologs if possible, write a description of fifologs and screenshots here to assist people unfamiliar with the game.]

What are your PC specifications? (CPU, GPU, Operating System, more)

Galaxy S7 Edge (SM-G935U)

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

I'd usually look back to see when the issue started or if it ever worked, but since it's broken in single-core, hopefully that's an obvious fix.


Related issues

Has duplicate Emulator - Emulator Issues #11217: Resident Evil archives 1 (GameCube) does not boot.Duplicate

History

#1 Updated by JosJuice almost 2 years ago

I don't think this is an obvious fix. A bisect would really be helpful.

#2 Updated by Tommy78 almost 2 years ago

JosJuice wrote:

I don't think this is an obvious fix. A bisect would really be helpful.

I'll invest more time soon.

#3 Updated by Tommy78 almost 2 years ago

Tommy78 wrote:

JosJuice wrote:

I don't think this is an obvious fix. A bisect would really be helpful.

I'll invest more time soon.

It's 5.0-2462

#4 Updated by JMC4789 almost 2 years ago

  • Regression start set to 5.0-2462
  • Regression changed from No to Yes
  • Milestone set to Current
  • Assignee set to degasus

#5 Updated by Tommy78 almost 2 years ago

Tommy78 wrote:

Tommy78 wrote:

JosJuice wrote:

I don't think this is an obvious fix. A bisect would really be helpful.

I'll invest more time soon.

It's 5.0-2462

Is there any ideas or updates here? This has got to be breaking many other things.

#6 Updated by Helios almost 2 years ago

If there isn't an update to the issue, there is nothing new.

#7 Updated by Tommy78 almost 2 years ago

Helios wrote:

If there isn't an update to the issue, there is nothing new.

Yeah. If you read between the lines it read "fix your broken stuff". That was the nice version. 🙄

#8 Updated by Helios almost 2 years ago

If you read between the lines, it read "stop being obnoxious". That was the nice version.

You're free to go use another Wii emulator.

#9 Updated by Helios almost 2 years ago

  • Operating system Android added
  • Operating system deleted (N/A)

#10 Updated by JMC4789 about 1 year ago

  • Assignee deleted (degasus)
  • Status changed from New to Accepted
  • Operating system N/A added
  • Operating system deleted (Android)

Happens on Desktop too.

#11 Updated by JMC4789 about 1 year ago

Also available in: Atom PDF