Project

General

Profile

Emulator Issues #10879

Sonic Riders: Zero Gravity, cutscenes not working

Added by wartomato about 1 year ago. Updated about 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name:
Sonic Riders: Zero Gravity (US release, though the region probably shouldn't have any effect on this bug)

Game ID:
RS9E8P

MD5 Hash:
8152b6ab8109a0144a1c9d8779a40aa6

Problem:
The game features prerendered video cutscenes at several points in story mode, as well as when booting up the game. However, when emulated, the cutscenes will not render at all, only playing the sound that comes with them and leaving a black screen instead.

How-to reproduce:
Simply open up the game, the SEGA logo and an intro cutscene should immediately attempt to play, only playing the corresponding audio instead.

Emulator version:
5.0-6309 (latest development version as of writing this)

Here's a 3-second (180 frames) fifolog taken around the beginning of the introductory cutscene (screenshots would be pointless as it's just a black screen):
https://www.dropbox.com/s/1sfqwa1dvc7ltt4/rec.dff?dl=0

PC Specifications:
CPU= Intel Core i5-6500 @3.20GHZ
GPU= NVidia Geforce GTX 970
OS= Windows 7 Ultimate, 64-bits
RAM= 16GB DDR4

Extra Info:
I have tried several graphical configurations and INI tweaks, to no avail. I have, however, noticed that going into the graphical settings while the game is open and a video cutscene is playing, and then changing the texture cache accuracy during that cutscene, causes the game's window to update to the current frame in the video cutscene, getting stuck on that frame instead. Changing that setting to "Safe" and rebooting the game does nothing to fix the issue, however.


Related issues

Is duplicate of Emulator - Emulator Issues #11164: TMEM emulation regressionsAccepted

History

#1 Updated by mstreurman about 1 year ago

Don't have this specific game, but did it ever work? and if so, which version did it stop working?

#2 Updated by wartomato about 1 year ago

mstreurman wrote:

Don't have this specific game, but did it ever work? and if so, which version did it stop working?

I actually didn't try the game until just now, when i was already using version 5.0-6309...
I did, however, just download version 5.0-9 (the closest portable version to 5.0, since i didn't want to have to go through the installer again) and the videos worked perfectly fine in that build, which means this specific function must have broken at some point between 5.0 and this version.

#3 Updated by JMC4789 about 1 year ago

I think we already have an issue for it, I think a texture cache optimization broke it.

#4 Updated by kolano about 1 year ago

Yeah, this seems to be a dup of https://bugs.dolphin-emu.org/issues/10639

#5 Updated by JosJuice about 1 year ago

#6 Updated by JosJuice about 1 year ago

  • Status changed from New to Duplicate

#7 Updated by wartomato about 1 year ago

kolano wrote:

Yeah, this seems to be a dup of https://bugs.dolphin-emu.org/issues/10639

Just to clarify, this isn't the same game despite the similar name, this is the sequel to the original sonic riders

Though both games run on the same engine and it's a similar problem so yeah, i suppose it may count as a duplicate in that sense

#8 Updated by JosJuice 9 months ago

#9 Updated by JosJuice 9 months ago

Also available in: Atom PDF