Project

General

Profile

Emulator Issues #10921

Wii menu doesn't respect changed default ISOs unless default ISO is cleared

Added by ryanebola16 over 2 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?

  1. Set a default ISO
  2. Install latest Wii System menu WAD if needed
  3. Launch Wii System menu
  4. Observe that the correct ISO is selected
  5. Exit emulation
  6. Choose a different game as the default ISO
  7. Launch Wii System menu
  8. Observe that the previous ISO is incorrectly selected. This persists after restarting Dolphin.

Unchecking your default ISO before picking a new default ISO is a workaround.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

5.0-6392

Is the issue present in the latest stable version?

No, 5.0

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

5.0-775 (Shut down Wii software gracefully)

What are your PC specifications? (CPU, GPU, Operating System, more)

Win 10 Pro x64
Intel Core i7-4702MQ CPU @2.20GHz
GeForce GT 750M
2x 8GB Hynix 1600MHz
GeForce Game Ready Driver 391.01

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

Originally reported in #10865 but was a separate issue.


Related issues

Is duplicate of Emulator - Emulator Issues #8115: Disc Channel displays wrong game if the disc is changed when emulation is not runningFixed

History

#1 Updated by leoetlino over 2 years ago

  • Is duplicate of Emulator Issues #8115: Disc Channel displays wrong game if the disc is changed when emulation is not running added

#2 Updated by leoetlino over 2 years ago

  • Status changed from New to Duplicate

This is a duplicate of #8115.

The system menu reads data about the inserted disc and stores it into a cache on the NAND. It doesn't appear to pick up disc changes that happen while it isn't running.

Also available in: Atom PDF