Project

General

Profile

Emulator Issues #10994

DolphinWX: crash in WiiConfigPane::LoadGUIValues() during shutdown

Added by flacs about 3 years ago. Updated almost 3 years ago.

Status:
Won't fix
Priority:
Normal
Assignee:
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Current
Regression:
Yes
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
5.0-5111
Fixed in:

Description

What's the problem? Describe what went wrong.
DolphinWX crashes if closed while the log config pane is enabled and the config dialog has been opened at least once.

What steps will reproduce the problem?
1. Open DolphinWX with an empty user config directory (e.g. with "dolphin-emu -u $(mktemp -d)").
2. Open config dialog.
3. Close config dialog.
4. Enable View->Show Log Configuration.
5. Close DolphinWX.
6. Enjoy the crash.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.
master

Is the issue present in the latest stable version?
didn't check

If the issue isn't present in the latest stable version, which is the first broken version?
too lazy to bisect, but it's probably caused by https://github.com/dolphin-emu/dolphin/commit/e471505632fb4bbba7ae6af27644a29c39d78516

What are your PC specifications?
Linux

Is there anything else that can help developers narrow down the issue?
(gdb) bt
#0 0x00005555577ad900 in ()
#1 0x000055555582f4de in WiiConfigPane::LoadGUIValues() (this=0x55555745ac70) at ../Source/Core/DolphinWX/Config/WiiConfigPane.cpp:183
#2 0x000055555596648f in std::function::operator()() const (this=0x7fffffffe2a0) at /usr/include/c++/7.3.1/bits/std_function.h:706
#3 0x000055555596648f in Core::HostDispatchJobs() () at ../Source/Core/Core/Core.cpp:978
#4 0x000055555590a209 in DolphinApp::OnExit() (this=0x5555571bad50) at ../Source/Core/DolphinWX/Main.cpp:362
#5 0x0000555555bf6ed3 in CallOnExit::~CallOnExit (this=, __in_chrg=) at ../Externals/wxWidgets3/src/common/init.cpp:497
#6 0x0000555555bf6ed3 in wxEntry(int&, wchar_t*) (argc=, argv=) at ../Externals/wxWidgets3/src/common/init.cpp:498
#7 0x00005555557adb28 in main(int, char
*) (argc=, argv=) at ../Source/Core/DolphinWX/Main.cpp:68

History

#1 Updated by leoetlino about 3 years ago

  • Regression start set to 5.0-5111
  • Milestone set to Current
  • Status changed from New to Accepted

This is fixed by https://github.com/dolphin-emu/dolphin/pull/5881/commits/be87280e66861acd766213e08b805fa7f5aa9b26 but it depends on PR 6264 (to clean up callbacks) which hasn't been merged yet :(

#2 Updated by ryanebola16 about 3 years ago

This could be related to #10458

#3 Updated by leoetlino almost 3 years ago

  • Status changed from Accepted to Won't fix

DolphinWX has been deprecated and the issue isn't present in DQt2.

Also available in: Atom PDF