Project

General

Profile

Emulator Issues #11032

Cannot apply any core options in games unless a change is also made to determinalistic dual core... Also Not set in dual core doesn't work and has the same function as auto.

Added by badkarma12 over 1 year ago. Updated over 1 year ago.

Status:
Invalid
Priority:
Normal
Assignee:
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

None of the check boxes in a game settings tab actually apply any changes except if a change other than not set is made to deterministic dual core. The not set option also does the same thing theoretically as auto at least according to the documentation and should be removed as an option. That said changing it to not set doesn't actually work anyway unless you delete it in the config files.

History

#1 Updated by spycrab0 over 1 year ago

I can't verify the validity of this at the moment. Could you see if this PR helps at all? https://github.com/dolphin-emu/dolphin/pull/6717

#2 Updated by spycrab0 over 1 year ago

  • Assignee set to spycrab0

#3 Updated by spycrab0 over 1 year ago

  • Status changed from New to Questionable

Setting to Questionable until further feedback is provided and this is retested with the latest master.

#4 Updated by badkarma12 over 1 year ago

Still broken has been since the switch to QT. The per game options are literally not writing to the config files, except for options other than not set for determinalistic dual core, which seems to force a write to every setting changed.

#5 Updated by badkarma12 over 1 year ago

All checkboxes in specific game settings are still broken as of 5.0-7229. Perhaps something to do with the fact that these aren't regular checkboxes and have three options instead of just checked or not? the write condition probably wouln't work with these if you jut coppied it from the other checkboxes,

#6 Updated by JMC4789 over 1 year ago

100% works for me in the latest dev build. Disabled MMU in Rogue Squadron 2 and then tried to boot the game. It exploded.

#7 Updated by spycrab0 over 1 year ago

  • Status changed from Questionable to Invalid

#8 Updated by JMC4789 over 1 year ago

I'm not saying it's 100% sure invalid, it's just that it works on my system.

Also available in: Atom PDF