Project

General

Profile

Actions

Emulator Issues #11092

closed

opengl efb acess broken in mario galaxy (3d3 works)

Added by Guitarkory1 almost 6 years ago. Updated almost 6 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Super mario Galaxy

Game ID? (right click the game in the game list, properties, info tab)

RMGE01

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

b742ff2212c76fccb7001bb1e4a2c7cc

What's the problem? Describe what went wrong.

when using opengl, you cant enter levels or shoot starbits with super mario galaxy. EFB access disabled box is not checkmarked, so efb access is not disabled

What steps will reproduce the problem?

1.play game with efb access (aka no checkmark on efb access disabled)

  1. try to shoot starbit or enter level
  2. rage quit because you can't enter a level or shoot starbits

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

dolphin version 7289

Is the issue present in the latest stable version?

no

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

internet slow, have to test later, will update

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

[Attach any fifologs if possible, write a description of fifologs and screenshots here to assist people unfamiliar with the game.]

What are your PC specifications? (CPU, GPU, Operating System, more)

i7 7700, nvidia 1070, windows 10 os, 32 gb ram

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

it works with 3d3 just fine, only opengl is broken. configuration is the same across backends.

Actions #1

Updated by JMC4789 almost 6 years ago

Could you bisect the issue to see when it was broken? Since 5.0 works and you said latest does not, that's the next logical step is to find what build broke it.

Actions #2

Updated by Guitarkory1 almost 6 years ago

I can bisect, my download speed is less than 1mbps right now, I can barely access this site (windows started downloading updates, my dl speed is usually 3mbps). I should have the report in a hour or so.

Actions #3

Updated by JMC4789 almost 6 years ago

If Windows is updating, they may have reset your graphics drivers. EFB Access is working fine for me on my computer (NVIDIA GTX 1070 as well.)

Actions #4

Updated by Guitarkory1 almost 6 years ago

If you were using 3d3 it works. It's only broken for opengl. windows hasnt updated yet, its still downloading (my download speed is so slow that it takes a few hours to download a feature update). Its donnload speed is so slow that right now it would take me 49 minutes to download another version of the dolphin emulator.

Actions #5

Updated by Guitarkory1 almost 6 years ago

it also works with vulkan, just not opengl for some reason

Actions #6

Updated by JMC4789 almost 6 years ago

Do you have any kind of overlay on? They can interfere with Dolphin's EFB Access.

Actions #7

Updated by Guitarkory1 almost 6 years ago

No overlay, I found the issue. Increasing the IR causes the efb access to break. when its at x1 it works, but when its at x6 its broken

Actions #8

Updated by Guitarkory1 almost 6 years ago

it breaks at anything higher than x1

Actions #9

Updated by Guitarkory1 almost 6 years ago

actually its only broken when I use msaa and increase the IR

Actions #10

Updated by Guitarkory1 almost 6 years ago

Guitarkory1 wrote:

actually its only broken when I use msaa and increase the IR

and again, only for opengl. 3d3 and vulkan are fine

Actions #11

Updated by JMC4789 almost 6 years ago

  • Status changed from New to Invalid

Unfortunately that's out of our control because of how the driver optimizes things.

While it's possible we make a hack/work-around, it'd be best to wait for everything to be moved to video common. And, as MSAA is an enhancement the game didn't naturally have, there's no guarantee it works in the first place.

Actions #12

Updated by Guitarkory1 almost 6 years ago

That's ok I don't need msaa. It turns out it works fine with just ir. I'm assuming 're installing my drivers won't fix anything?

Actions

Also available in: Atom PDF