Project

General

Profile

Emulator Issues #11148

Project M / Legacy TE launcher doesn't run

Added by davidvkimball about 2 years ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Current
Regression:
Yes
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Super Smash Bros. Brawl / Project M

Game ID? (right click the game in the game list, properties, info tab)

RSBE01

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

d18726e6dfdc8bdbdad540b561051087

What's the problem? Describe what went wrong.

Basically a Wii will open the attached .elf files normally and launch Project M / Legacy TE. However, this only works on 2GB SD cards and below. On Dolphin, the latest version I could find that works with it is Dolphin 5.0-1987. Versions after that do not work with it at all on sd.raws 2GB and under.

What steps will reproduce the problem?

Set Brawl as the default ISO, and have the Legacy TE files or Project M files on your SD card. Open the corresponding boot.elf file (TE.elf for TE, and PM.elf for PM), nothing will happen and the game will not launch.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

5.0-7651

Is the issue present in the latest stable version?

It is not present, works perfectly fine in 5.0 proper.

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

Any version after 5.0-1987 doesn't work with it.

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

This issue is not graphically-related.

What are your PC specifications? (CPU, GPU, Operating System, more)

Windows 10 Pro, Intel Core i7, GTX 770, more here: http://davidvkimball.com/pc

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

I've attached files called TE.elf and PM.elf for you to test. Legacy TE can be downloaded here (files to go on the virtual SD card): http://smashbros.co/te and Project M can be downloaded here: http://projectmirror.no-ip.org/

TE.elf (1.55 MB) TE.elf Legacy TE boot.elf file davidvkimball, 05/20/2018 08:39 PM
PM.elf (1.55 MB) PM.elf Project M boot.elf file davidvkimball, 05/20/2018 08:39 PM

Related issues

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by JosJuice about 2 years ago

Just to make sure, have you tested that 5.0-1991 doesn't work, or have you only tested that 5.0-1993 doesn't work? (Either way, it seems like a very strange bisect...)

#2 Updated by JosJuice about 2 years ago

  • Regression changed from No to Yes
  • Milestone set to Current
  • Subject changed from Dolphin Doesn't Respect Custom Boot.Elf File like Wii Does to Project M / Legacy TE launcher doesn't run

#3 Updated by JMC4789 about 2 years ago

  • Status changed from New to Accepted

It's a strange bisect, but we do know that it is broken in latest builds. It could be due to missing IOSes and stuff and hacks being removed...

This needs more testing.

#4 Updated by FoxReinherz over 1 year ago

Bumping this because some controllers simply don't work in 5.0-1987 so I can't play Legacy TE.

#5 Updated by waffeln over 1 year ago

@FoxReinherz It works when you launch the .elf through the Netplay window. It's a decent workaround for now.

#6 Updated by JMC4789 over 1 year ago

  • Status changed from Accepted to Duplicate

Is a dualcore issue. Enable Deterministic Dualcore (aka Netplay Dualcore) or Single Core to fix.

#7 Updated by JMC4789 over 1 year ago

Also available in: Atom PDF