Project

General

Profile

Emulator Issues #11217

Resident Evil archives 1 (GameCube) does not boot.

Added by SnapDragon over 1 year ago. Updated 11 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
% Done:

0%

Operating system:
Android
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

I have Huawei mate 10 pro and Resident Evil archives 1 does not want to start it shows me two warning. look at the screens. I am using the last version of Dolphin emulator... Sorry for my bad English and hope someone can help me

Screenshot_20180610-172456.jpg (308 KB) Screenshot_20180610-172456.jpg SnapDragon, 06/10/2018 03:26 PM
Screenshot_20180610-172459.jpg (329 KB) Screenshot_20180610-172459.jpg SnapDragon, 06/10/2018 03:26 PM
Screenshot_2018-06-11-01-29-40.png (115 KB) Screenshot_2018-06-11-01-29-40.png SnapDragon, 06/10/2018 11:33 PM
6845
6846
6847

Related issues

Is duplicate of Emulator - Emulator Issues #10877: RE0 Single-core brokenAccepted

Has duplicate Emulator - Emulator Issues #11569: Resident Evil 1Duplicate

History

#1 Updated by JosJuice over 1 year ago

Have you tried disabling dual core, like the first error message says?

#2 Updated by SnapDragon over 1 year ago

JosJuice wrote:

Have you tried disabling dual core, like the first error message says?

Yes but after the game Crash

#3 Updated by JosJuice over 1 year ago

  • Operating system Android added
  • Operating system deleted (N/A)

#4 Updated by SnapDragon over 1 year ago

JosJuice wrote:

Have you tried disabling dual core, like the first error message says?

Oh I forgot that this problem does not occur on an older version like 5.0-540

#5 Updated by JMC4789 over 1 year ago

then please bisect and find out when it stopped working. that way we can fix it.

#6 Updated by SnapDragon over 1 year ago

6847

JMC4789 wrote:

then please bisect and find out when it stopped working. that way we can fix it.

Found. With version 5.0-5833 it works perfectly and with version 5.0-5874 it does not work anymore.
Thanks for the support and I hope this bug will be fixed as soon as possible

#7 Updated by SnapDragon over 1 year ago

JMC4789 wrote:

then please bisect and find out when it stopped working. that way we can fix it.

Any news?

#8 Updated by SnapDragon over 1 year ago

Have you fixed the bug?

#9 Updated by JMC4789 over 1 year ago

So you're saying HybridXFB broke it?

I tested it on latest master on non-Android and it's working fine. It could be an issue with the AArch64 JIT, so, try using the cached interpreter to boot it.

#10 Updated by SnapDragon over 1 year ago

JMC4789 wrote:

So you're saying HybridXFB broke it?

I tested it on latest master on non-Android and it's working fine. It could be an issue with the AArch64 JIT, so, try using the cached interpreter to boot it.

Same not working

#11 Updated by JMC4789 over 1 year ago

What version of the game do you have? PAL?

#12 Updated by SnapDragon over 1 year ago

JMC4789 wrote:

What version of the game do you have? PAL?

Yes

#13 Updated by JMC4789 over 1 year ago

  • Assignee set to degasus

It's probably a legitimate regression with Hybrid XFB then.

#14 Updated by SnapDragon over 1 year ago

JMC4789 wrote:

It's probably a legitimate regression with Hybrid XFB then.

then?

#15 Updated by JMC4789 over 1 year ago

Considering that it's a PAL version of a game that no one on the team has... either use an older version or try to investigate it yourself until someone is interested enough to check it out themselves. Because HybridXFB had so many issues with PAL games early on, it seems likely that this game uses a strange video mode. I have the NTSC version and everything is fine there.

I'll try to trick the game into running in PAL mode with a bootloader and see what happens personally and report it forward. I can't promise anything will change soon, though.

#16 Updated by JMC4789 over 1 year ago

Okay, after some testing.

A shitty work-around that works in my modified NTSC version is setting the emulated CPU Clock to 6% on boot with single core. Once the game is running it seems to be fine to set the CPU clock to whatever you want.

I'll continue to investigate though.

#17 Updated by JMC4789 over 1 year ago

  • Subject changed from Resident Evil archives 1 (GameCube) does not want to start to Resident Evil archives 1 (GameCube) does not boot.

So I did a lot more testing and finally figured things out.

This game has actually never worked in Dolphin's XFB paths - it relied on a lack of emulation. No XFB, which was replaced by Immediately Present XFB copies, emulated so little that whatever is tripping up Dolphin now wasn't an issue. Therefore this isn't exactly a regression (and the bisect isn't as useful) but it at least gives us a starting point to investigation.

The base issue report for this issue kind of sucks (you didn't follow the issue template, which resulted in a lot of wasted time...) so I may replace this issue once I have the actual game instead of relying on a hacked ISO.

#18 Updated by SnapDragon over 1 year ago

JMC4789 wrote:

So I did a lot more testing and finally figured things out.

This game has actually never worked in Dolphin's XFB paths - it relied on a lack of emulation. No XFB, which was replaced by Immediately Present XFB copies, emulated so little that whatever is tripping up Dolphin now wasn't an issue. Therefore this isn't exactly a regression (and the bisect isn't as useful) but it at least gives us a starting point to investigation.

The base issue report for this issue kind of sucks (you didn't follow the issue template, which resulted in a lot of wasted time...) so I may replace this issue once I have the actual game instead of relying on a hacked ISO.

Thank you

#19 Updated by JMC4789 11 months ago

#20 Updated by JMC4789 11 months ago

  • Status changed from New to Duplicate

#21 Updated by JMC4789 10 months ago

Also available in: Atom PDF