Project

General

Profile

Emulator Issues #11246

Metroid Prime 3 crashes sometimes after closing the map

Added by danileon95 about 2 years ago. Updated about 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Metroid Prime 3 (Metroid Prime Trilogy)

Game ID? (right click the game in the game list, properties, info tab)

R3MP01

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

735c0d0c16177e3294f5e0faf7a69571

What's the problem? Describe what went wrong.

Sometimes after closing the map after you're given a mission or a location tip, the game will have a long stutter that makes me feel as if the emulator is screaming at me for daring play this game, and sometimes after that stutter Dolphin will just close. No error or anything, it just throws me out of the game, as if it was tired of my crap. This has happened twice to me. I've also screamed twice.

What steps will reproduce the problem?

Play Prime 3, receive a mission location (this part might be unrelated, but both crashes have been after receiving mission data and getting the map opened automatically, not after opening the map manually), close the map, watch your screen suddenly transition from a beautiful game called Metroid Prime 3: Corruption to your stupid desktop, get pissed at your lost progress.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes, 5.0-8253

Is the issue present in the latest stable version?

I don't know.

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

I'm not sure how to test an apparently rare crash like this.

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

Again, not sure how to record a fifolog of this, considering the crash is random and Dolphin just closes.

What are your PC specifications? (CPU, GPU, Operating System, more)

i7 6700k 4.2 GHz
Nvidia GTX 1070 8 GB (latest drivers)
16 GB DDR4 RAM
Windows 10 64 Bits
Vulkan backend, asynchronous ubershaders, GPU texture decoding enabled to avoid stutters when opening doors.

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

My savefile I guess, as I got this last crash not too long after saving. I got the location of the mission sent to me, pressed 1 to open the map, closed it, bam, crash. This save data is for the PAL version of Metroid Prime Trilogy.

private.zip (173 KB) private.zip danileon95, 06/27/2018 07:08 PM

Related issues

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by Techjar about 2 years ago

Testing has shown this game has some stability issues with dual core. Try using single core, your CPU should be able to handle it.

#2 Updated by danileon95 about 2 years ago

I played a bit in single core mode now and no crashes happened for now, will report if that changes, thanks!

#3 Updated by danileon95 about 2 years ago

I can confirm that the crashes don't happen at all when in single core mode. It's a shame tho, I can maintain fullspeed most of the time in single core mode, but not all the time, some demanding fights have drops :(

#4 Updated by JMC4789 about 2 years ago

  • Status changed from New to Duplicate

yeah well that's the catch with dualcore. You can trade stability for speed.

#5 Updated by JMC4789 about 2 years ago

Also available in: Atom PDF