Project

General

Profile

Emulator Issues #11251

Wii U Gamecube Adapter Not Working on OSX High Sierra

Added by SoaringHawk820 almost 2 years ago. Updated almost 2 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
OS X
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What's the problem? Describe what went wrong.

When trying to play Dolphin on Mac using the official Wii U Gamecube Adapter, it is not being detected. I have tried reinstalling the driver, https://forums.dolphin-emu.org/attachment.php?aid=16638, multiple times and nothing seems to be fixing the problem.

What steps will reproduce the problem?

  1. Install Dolphin (doesn't matter the version)
  2. Install the driver for the adapter
  3. Plug the adapter into the computer

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes, 5.0-8285

Is the issue present in the latest stable version?

Yes, 5.0

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

It is not broken in a specific dolphin build, but rather a problem with the OS

What are your PC specifications? (CPU, GPU, Operating System, more)

2015 Macbook Pro
macOS High Sierra Version 10.13.5
2.8 GHz Intel Core i7
16 GB 1600 MHz DDR3
AMD Radeon R9 M370X 2048 MB

History

#1 Updated by JosJuice almost 2 years ago

  • Status changed from New to Questionable
  • Operating system OS X added
  • Operating system deleted (N/A)

Did you turn off SIP?

#2 Updated by SoaringHawk820 almost 2 years ago

No, because isn't that only for terminal install?

#3 Updated by JosJuice almost 2 years ago

  • Status changed from Questionable to Invalid

No, you're required to turn off SIP on macOS 10.11 and later regardless of how you install the kext.

Also available in: Atom PDF