Project

General

Profile

Actions

Emulator Issues #11258

closed

Qt/MappingWindow: Controller profile names containing asterisks cause problems

Added by 8times9 over 4 years ago. Updated over 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Steps to reproduce:

  1. Type in the controller profile name box and use a name that has an asterisk anywhere in it (beginning, end, middle, etc)
  2. Save the profile
  3. The controller profile appears to have been saved and appears in the list of profiles
  4. Click Delete to try to delete the profile
  5. Dolphin reports that no such profile exists, even though it appeared to save it It seems the profile never gets saved. If you save the asterisk-named profile, and then close and reopen the mapping window, it is absent from the profile list.

If this is a technical limitation Dolphin should not allow the user to save a profile with asterisks in the name in the first place.


Related issues

Is duplicate of Emulator - Emulator Issues #9391: Controller Profile naming doesn't filter out characters with special meaningsAcceptedBilliard26

Actions
Actions #1

Updated by Techjar over 4 years ago

Yeah this shouldn't be allowed, as asterisks are treated as a special character on all OSes.

Actions #2

Updated by JosJuice over 4 years ago

  • Is duplicate of Emulator Issues #9391: Controller Profile naming doesn't filter out characters with special meanings added
Actions #3

Updated by JosJuice over 4 years ago

  • Status changed from New to Duplicate
Actions

Also available in: Atom PDF