Project

General

Profile

Emulator Issues #11261

Missing blocks

Added by Jasonrebe over 2 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

New super mario bros wii

Game ID? (right click the game in the game list, properties, info tab)

SMNE01

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

d042da527c766e76c13db624e3166f43

What's the problem? Describe what went wrong.

The blocks are invisible and does not show in the emulator. If I play this on a Wii, it shows block textures

What steps will reproduce the problem?

Play any level in the game

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

5.0-8316

Is the issue present in the latest stable version?

No 5.0

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

[First broken version number here (if applicable)]

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

[Attach any fifologs if possible, write a description of fifologs and screenshots here to assist people unfamiliar with the game.]

What are your PC specifications? (CPU, GPU, Operating System, more)

Macbook pro 13 inch
Macos 10.13.5

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

No


Related issues

Is duplicate of Emulator - Emulator Issues #10966: New Super Mario Bros on macOS requires EFB copies to RAMAccepted

History

#1 Updated by Techjar over 2 years ago

Please bisect to find which build it broke in.

#2 Updated by Jasonrebe over 2 years ago

Quote
Description

Game Name?

New super mario bros wii

Game ID? (right click the game in the game list, properties, info tab)

SMNE01

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

d042da527c766e76c13db624e3166f43

What's the problem? Describe what went wrong.

The blocks are invisible and does not show in the emulator. If I play this on a Wii, it shows block textures

What steps will reproduce the problem?

Play any level in the game

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

5.0-8316

Is the issue present in the latest stable version?

No 5.0

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

5.0-8316

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

[Attach any fifologs if possible, write a description of fifologs and screenshots here to assist people unfamiliar with the game.]

What are your PC specifications? (CPU, GPU, Operating System, more)

Macbook pro 13 inch
Macos 10.13.5

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

No

#3 Updated by Jasonrebe over 2 years ago

It was in dolphin 5.0-8316

#4 Updated by Techjar over 2 years ago

So you're saying it works on any build prior to that?

#5 Updated by Jasonrebe over 2 years ago

No

#6 Updated by Techjar over 2 years ago

You need to clone the git repo, use git bisect and build it yourself to find which build it broke in, as per the text in the template.

#7 Updated by 8times9 over 2 years ago

Can confirm, this only occurs on macOS AFAIK.

#8 Updated by Jasonrebe over 2 years ago

Yes

#9 Updated by JosJuice over 2 years ago

#10 Updated by JosJuice over 2 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF