Project

General

Profile

Emulator Issues #11310

Brawl VC OOT Slowdown

Added by bluebird747 over 1 year ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Super Smash Bros. Brawl

Game ID? (right click the game in the game list, properties, info tab)

RSBE01

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

d18726e6dfdc8bdbdad540b561051087

What's the problem? Describe what went wrong.

In the OOT masterpiece of Super Smash Bros. Brawl, there is significant slowdown in most of the open areas (such as Kokiri Village and Hyrule Field). When I went to test it on the Wii, I noticed that the slowdown was gone. There was also no slowdown on emulating the OOT WAD. I got the same amount of slowdown on integrated graphics (Intel HD 630) as I did on my dedicated graphics (Nvidia GTX 1060).

What steps will reproduce the problem?

  1. Start Super Smash Bros. Brawl
  2. Navigate to the Masterpieces section and start The Legend of Zelda: Ocarina of Time
  3. Pick the first file and walk outside of Link's house

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes - 5.0 - 8512

Is the issue present in the latest stable version?

Yes - 5.0

What are your PC specifications? (CPU, GPU, Operating System, more)

CPU - Intel i7-7700HQ
GPU - Nvidia GTX 1050
OS - Windows 10
RAM - 16GB

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

-


Related issues

Is duplicate of Emulator - Emulator Issues #11330: Dolphin's Emulated CPU is Too Slow/Fast in Various SituationsNew

History

#1 Updated by bluebird747 over 1 year ago

I forgot to fill out the top section so here is the relevant info:

OS: Windows 10

Relates to performance: Yes

#2 Updated by bluebird747 over 1 year ago

Also, there is a typo in my response for the problem: I meant to write 1050 rather than 1060.

#3 Updated by JMC4789 over 1 year ago

I bet it's because we don't disable branch following on the Super Smash Bros. Brawl N64 games lol

#4 Updated by JMC4789 over 1 year ago

Also our CPU cycle accuracy isn't very good either, which is a significant problem. If you up the CPU clock maybe it'll run better.

#5 Updated by bluebird747 over 1 year ago

Yeah, increasing the CPU clock did increase the performance in the area.

#6 Updated by JMC4789 over 1 year ago

I don't know if there's much we can do about it. I think we already have an issue report for this though. I'll look for it later.

#7 Updated by JMC4789 over 1 year ago

  • Status changed from New to Duplicate

Merging into the old issue.

#8 Updated by JMC4789 over 1 year ago

Also available in: Atom PDF