Project

General

Profile

Emulator Issues #11396

Mario Kart Wii - Controlling Problem

Added by paparansen over 2 years ago. Updated over 2 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Mario Kart Wii

Game ID? (right click the game in the game list, properties, info tab)

Tried US, EUR & JAP Version

What's the problem? Describe what went wrong.

Sometimes ( but in every Race ) the Steering ( left & right ) do not work correct,
i do 100% left on Controller, but it is like only 50%, so i cant get around turns & corners.

What steps will reproduce the problem?

I donĀ“t know

**Is the issue present in the latest development version?

Yes

[Version number here]

Is the issue present in the latest stable version?

Yes

What are your PC specifications? (CPU, GPU, Operating System, more)

3570k, 1070ti, 16gb Ram, Windows 7, Xbox One Controller & Xbox 360 Controller

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

Please tell me exactly what you need.

History

#1 Updated by JosJuice over 2 years ago

What kind of controller are you using? Real Wii Remote? Emulated Wii Remote? GameCube controller?

#2 Updated by paparansen over 2 years ago

As mentioned above, i am using Xbox One & Xbox 360 Controller.
The emulated Controller is a Wii Remote & Classic Extension.

#3 Updated by Craftyawesome over 2 years ago

Does the red dot go all the way to the left/right in the extension configuration menu? Your radius may be set lower than 100.

#4 Updated by paparansen over 2 years ago

Yes, everything fine there.

#5 Updated by Daniel15 over 2 years ago

I'm seeing the same issue with a wired Logitech F310 controller, but NOT with an Xbox wireless bluetooth controller

#6 Updated by JMC4789 over 2 years ago

The best thing I could say to do is to turn on "Background Input", keep the game window AND the controller config window open (so we can see the red dot) and record both windows with OBS. That way we can see exactly what's going on during the difficulties.

Needless to say, I can't reproduce the issue on my PS4 controller or Native GC input, but, I've seen enough people complain that I'm rather interested to see what's going on.

#7 Updated by Billiard26 over 2 years ago

Are savestates being used?

#8 Updated by JMC4789 over 2 years ago

  • Status changed from New to Invalid

No response + I can't reproduce it with Xbox 360, PS3, PS4 or Native controllers.

Assuming user error.

Also available in: Atom PDF