Project

General

Profile

Emulator Issues #11410

"Always Hide Mouse Cursor" setting not always honored

Added by Bezier89 4 months ago.

Status:
New
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What's the problem? Describe what went wrong.

It doesn't happen every time, but often enough to be annoying - the mouse cursor is still visible when I launch a game in fullscreen. This is despite the fact that I have the "Always Hide Mouse Cursor" setting turned on. Note that you might need the "Compile Shaders Before Starting" option enabled to reproduce this (see next section).

What steps will reproduce the problem?

I've noticed the problem is substantially more likely to occur when compiling shaders ("Compile Shaders Before Starting" is enabled) takes a long time. In particular, after updating my graphics drivers, this issue happens for pretty much every game the first time it's launched. If I quit and relaunch (so compiling shaders stage is very fast), the issue does not usually reproduce.

Note: I am launching my games via LaunchBox with the -b and -e flags.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes - tested in 5.0-8785

Is the issue present in the latest stable version?

Probably not, given that it doesn't even have uber shaders!

What are your PC specifications? (CPU, GPU, Operating System, more)

CPU: Intel Core i3-4170T
GPU: Nvidia GeForce 860m
OS: Windows 10 64 Bit

Also available in: Atom PDF