Project

General

Profile

Emulator Issues #11436

Mario Kart Double Dash

Added by Forscythe over 2 years ago. Updated over 2 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

[Mario Kart Double Dash]

Game ID? (right click the game in the game list, properties, info tab)

[GM4E01]

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

[e42af970bba75e2db8ded97049a2e5f0]

What's the problem? Describe what went wrong.

[The game crashes after booting, both with the GC Bios Intro played and if skipped. It produces the error "SI: Unknown direct command"]

What steps will reproduce the problem?

[Simply starting the game]

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

[Yes 5.0-8949]

Is the issue present in the latest stable version?

[No]

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

[5.0-8764]

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

[Attach any fifologs if possible, write a description of fifologs and screenshots here to assist people unfamiliar with the game.]

What are your PC specifications? (CPU, GPU, Operating System, more)

[PC specs here]

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

[Anything else here]

Mario Kart DD crash.jpg (2.59 MB) Mario Kart DD crash.jpg Crash Screenshot Forscythe, 10/28/2018 02:09 AM
mario kart.dff (3.47 MB) mario kart.dff tony971, 12/05/2018 02:59 AM
7051

History

#1 Updated by MayImilae over 2 years ago

  • Status changed from New to Invalid

The MD5 hash of your game is unknown, so it looks like you have a bad dump. Redump the game and it should be fine.

#2 Updated by tony971 over 2 years ago

I don't crash, but get the "SI: Unknown Direct Command" warnings. Hash: 97f9ebc39ab4244e419848793988561a

#3 Updated by tony971 over 2 years ago

Here's a FIFO log capturing the errors.

#4 Updated by tony971 over 2 years ago

Narrowed it down to happening when "GameCube Adapter for Wii U" is selected as a controller option without being plugged.

Also available in: Atom PDF