Project

General

Profile

Emulator Issues #11465

With Mayflash 2-port GameCube adapter and genuine GameCube controllers, rumble works in Windows but not in Dolphin

Added by huginn 20 days ago. Updated 5 days ago.

Status:
New
Priority:
Normal
Assignee:
% Done:

0%

Operating system:
Windows
Issue type:
Bug
Milestone:
Current
Regression:
Yes
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
5.0-5522
Fixed in:

Description

Game Name?

I tested it in SSX3 because that was the quickest way I knew of off hand, but it is also broken in other titles, such as various Mario Party games.

Game ID? (right click the game in the game list, properties, info tab)

See above; SSX 3 is GXBE69

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

See above; SSX 3 is fb6ce25daf8550dae472b8d84596acc1.

What's the problem? Describe what went wrong.

When using the Mayflash 2-port GameCube adapter (Mayflash PC051), rumble works in Windows but not in game. (Not just the rumble test feature, which has been broken for the Mayflash 2-port adapter since 5.0-4607, but actually rumble in game.)

What steps will reproduce the problem?

  1. Install the drivers for the Mayflash 2-port GameCube adapter (Mayflash PC051): http://www.mayflash.com/File.asp?Id=74

  2. Plug in the Mayflash 2-port GameCube adapter (Mayflash PC051). It looks like this: http://www.mayflash.com/Up/day_120604/201206041210426725.jpg

  3. Plug in a genuine GameCube controller.

  4. Open the Windows Game Controllers properties. With the Mayflash driver installed, the tabs should look like this: https://i.postimg.cc/903K6CJ6/Mayflash-PC051.png

  5. Try the rumble test in this Windows dialog box. The rumble feature should work. (It works fine for me.)

  6. Unzip a clean installation of Dolphin 5.0-5509, and set up the GameCube controller mappings something like this: https://i.postimg.cc/5NKqynM0/rumble-works.png. (Anything just so the rumble feature is set to something.)

  7. Start a game that uses controller rumble. (If you have SSX 3, starting a race is a super-quick way: the controller should rumble as soon as the race begins.) The rumble will work fine.

  8. Then unzip a clean installation of Dolphin 5.0-5522, and play the same point in the same game. Rumble does not work.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes, the issue is present in 5.0-9155.

Is the issue present in the latest stable version?

This issue was not present through 5.0-5509; it began in 5.0-5522 (https://dolphin-emu.org/download/dev/2b4bf8662a18b8b3a49e67133f3e2e2fa45322b6/).

What are your PC specifications? (CPU, GPU, Operating System, more)

i5-4690K @ 4.2 GHz, 2GB GeForce 960, Windows 7 x64

GCPadNew.ini (2.69 KB) GCPadNew.ini huginn, 12/10/2018 02:40 PM

Related issues

Related to Emulator - Emulator Issues #10609: Wheel force feedback (Logitech DFGT) does not workNew

History

#1 Updated by huginn 20 days ago

I’m sorry, that’s a bad title: “not” should read “no longer”.

#2 Updated by huginn 19 days ago

Also, note that rumble does work for, say, the Mayflash 4-port Wii U adapter (Mayflash W012). It broke specifically for the 2-port adapter after 5.0-5522.

This is a big deal for my family for some games, because the 4-port adapter doesn’t allow the remapping of controls in “GameCube Adapter for Wii U” mode, whereas the 2-port adapter does allow it in “Standard Controller” mode—and for accessibility reasons we use the standard DirectInput controller mode to play with remapped controls on a number of titles.

#3 Updated by JosJuice 19 days ago

  • Regression start set to 5.0-5522
  • Regression changed from No to Yes
  • Milestone set to Current

#4 Updated by JosJuice 19 days ago

#5 Updated by Billiard26 6 days ago

  • Operating system Windows added
  • Operating system deleted (N/A)

Where can I acquire this adapter for testing? It seems to be unavailable on Amazon and eBay.

#7 Updated by Zexaron 6 days ago

It's on Amazon.de as it was when I got the 4-port one couple of years ago.

https://www.amazon.de/MAYFLASH-Gamecube-Controller-Adapter-Zwei-Ports-Schwarz/dp/B00YH2TGYS/ref=sr_1_6

#8 Updated by huginn 6 days ago

That one on Amazon.de is also on U.S. eBay and Amazon, but it’s not the older version I’m experiencing this problem with; it’s one with a Wii U/PC switch in the back (such as is in the back of the newer 4-port ones that are working fine).

I’m not sure whether that makes a difference, but I’m inclined to think it might. This issue seems to be affecting older DirectInput adapters specifically.

#9 Updated by Billiard26 5 days ago

huggin, that eBay listing has sold and I'm not finding any more listings. :/

#10 Updated by Techjar 5 days ago

That bisect makes me suspicious. 5.0-5522 is just changes to expression handling, which makes me think the issue is not the device itself, but a configuration parsing issue. Could you provide your controller config file?

Also for what it's worth, the Mayflash 4-port adapter has a switch for Wii U and PC modes, which will allow you to use it like a normal DirectInput controller.

#11 Updated by huginn 5 days ago

Sure thing. Here’s my \Dolphin\User\Config\GCPadNew.ini file (that’s the one you’re wanting, yes?).

Using this file, if I paste the 5509 release into my Dolphin folder, controller rumble works.

Still using this file, if I paste the 5522 release (the next after 5509) into my Dolphin folder, controller rumble stops working.

#12 Updated by huginn 5 days ago

Okay, I set the newer (4-port) Mayflash controller to DInput (PC) mode, and it is experiencing the same problem: rumble works up through 5.0-5509 but stops from 5.0-5522 on.

So @Billiard26, I guess it doesn’t much matter which Mayflash adapter you get so long as you can run it in DInput mode?

#13 Updated by huginn 5 days ago

Also, as a preliminary check of the configuration file issue myself, I cleared all DInput mappings and mapped them from scratch using the newest build of Dolphin. Rumble didn’t work.

I then dropped build 5509 directly onto that installation and tried again without making any other changes (using the config file generated by from-scratch mapping in the newest build of Dolphin). Rumble worked.

When I dropped 5522 directly onto the 5509 installation, rumble broke again.

Is it possible that changes to the expression handling failed to update some routine that is called when Dolphin sends rumble instructions to the controller?

Regardless, thank you all those who are even taking a look at this issue. For now my family can just stick with 5509 (we have an accessibility issue that requires controller remapping), but it would be great, for long-term compatibility and a million other obvious reasons, to be able to stay current with the update track.

So I’m very grateful for anything you can do.

#15 Updated by huginn 5 days ago

Probably either would work, but I was able to replicate it just now using B00RSXRLUE (the 4-port).

I don’t want people to be out money on my issue, though. I would be happy to reimburse you for the expense of purchasing an adapter you yourself don’t even need—let me know and if so I can give you an e-mail address you can contact me at so I can PayPal you enough to cover the purchase of the adapter.

You would need a GameCube controller as well, though. I’m assuming you already have one? If so, then do you already have a different adapter that works?

Anyway, let me know and I’ll be happy to pitch in.

#16 Updated by huginn 5 days ago

For reference, using the 4-port adapter on Windows requires installation of Mayflash’s driver (http://www.mayflash.com/File.asp?Id=89) and possibly (I have) updating to the latest (years old now) firmware (http://www.mayflash.com/File.asp?Id=106).

To use the adapter in DInput mode, the switch in the back should be set to “PC”.

#17 Updated by Billiard26 5 days ago

The 4-port adapter is on order to fix this. (ETA Dec 27) :)

#18 Updated by Billiard26 5 days ago

  • Assignee set to Billiard26

Also available in: Atom PDF