Project

General

Profile

Emulator Issues #11468

Shader Compilation re-running in played-through spots

Added by myth-p 5 months ago. Updated 5 months ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

[Taiko no Tatsujin Wii 5]

Game ID? (right click the game in the game list, properties, info tab)

[S5KJAF]

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

[Put MD5 Hash here]

What's the problem? Describe what went wrong.

[While playing through a song, it may stop at random times.
Even after completing it, playing it again on the same difficulty, it will pause at another point.]

What steps will reproduce the problem?

[Step 1: Play a song at any difficulty

Step 2: Play it again, the difficulty does not matter]

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

[Issue was found in Dolphin 5.0-9156.]

Is the issue present in the latest stable version?

[Yes, in Dolphin 5.0]

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

[First broken version number here (if applicable)]

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

[Attach any fifologs if possible, write a description of fifologs and screenshots here to assist people unfamiliar with the game.]

What are your PC specifications? (CPU, GPU, Operating System, more)

[CPU: Intel Core i7-7700 HQ @ 2.80GHz
GPU: NVIDIA GeForce GTX 1050
OS: Windows 10 Home]

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

[Anything else here]

History

#1 Updated by JMC4789 5 months ago

Are you sure it's shader generation and not some other kind of stuttering? There is more that can cause a game to stutter than shaders.

#2 Updated by myth-p 5 months ago

JMC4789 wrote:

Are you sure it's shader generation and not some other kind of stuttering? There is more that can cause a game to stutter than shaders.

...to be honest, I´m not that sure. However, most reports I found mention it as the cause, and the same problem happens no matter what. Even if nothing besides Dolphin is opened with the charger being plugged in, the game won´t stop pausing.

What other ways are there to check whats wrong?

#3 Updated by JMC4789 5 months ago

It could be something like the JIT cache spilling out. The only way to test that is to make bigger caches and see if it happens less often.

#4 Updated by myth-p 5 months ago

JMC4789 wrote:

It could be something like the JIT cache spilling out. The only way to test that is to make bigger caches and see if it happens less often.

I would test this, but I am currently unable to reproduce the issue, so i guess it was just something with my laptop.
..is there any way I can mark this as cleared up?

#5 Updated by JosJuice 5 months ago

  • Status changed from New to Invalid

No, but I can mark it for you if you want to.

Also available in: Atom PDF