Project

General

Profile

Emulator Issues #11479

INVISIBLE CHARACTERS

Added by Alberto 9 days ago. Updated 2 days ago.

Status:
Won't fix
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Dragon Ball Revenge of king piccolo

Game ID? (right click the game in the game list, properties, info tab)

R7GPAF (0001000052374750)

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

1ebb58e5e4e8c83b428ebfdb32040e36

What's the problem? Describe what went wrong.

Goku and her enemies are invisibles, sound and other graphics are ok but the characters are invisibles, their shadows are visibles .

What steps will reproduce the problem?

When you start to play normally. I tested with a lot of versions. I have te newer one.

Sorry for my english , i know its terrible.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

[Version number here]

Is the issue present in the latest stable version?

[Yes/No and version number here]

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

[First broken version number here (if applicable)]

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

[Attach any fifologs if possible, write a description of fifologs and screenshots here to assist people unfamiliar with the game.]

What are your PC specifications? (CPU, GPU, Operating System, more)

[PC specs here]

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

[Anything else here]

History

#1 Updated by JMC4789 9 days ago

Hey, we understand you're having difficulty with the language barrier, but, the template is not optional.

Can you tell me what device you're using? Are you on an Android phone or Desktop PC?

#2 Updated by Alberto 9 days ago

JMC4789 wrote:

Hey, we understand you're having difficulty with the language barrier, but, the template is not optional.

Can you tell me what device you're using? Are you on an Android phone or Desktop PC?

Sorry but i can't find the template to fill it or i did it in the wrong way. here are my specifications system

MacBook Pro
Identificador del modelo: MacBookPro11,1
Nombre del procesador: Intel Core i5
Velocidad del procesador: 2,4 GHz
Cantidad de procesadores: 1
Cantidad total de núcleos: 2
Caché de nivel 2 (por núcleo): 256 KB
Caché de nivel 3: 3 MB
Memoria: 8 GB
Versión de la ROM de arranque: 149.0.0.0.0
Versión SMC (sistema): 2.16f68

All the games i tested before run well , so first of all thank you for that amazing "tool"

#3 Updated by JMC4789 9 days ago

Thank you, I'll look into it and see if I have the issue. Does it happen right away in the first level.

#4 Updated by Alberto 9 days ago

Yes it happen right away in the first stage, the main menu looks perfect but when the first stage begin goku and her enemies are invisible.

#5 Updated by Zexaron 9 days ago

Whoa, is it a good idea to have UUID and system serial numbers in public like that. Isn't that used by law enforcement for stolen property or Apple remote locking? Just wondering.

#6 Updated by JMC4789 9 days ago

We don't need it for debugging so I removed it just in case.

#7 Updated by Alberto 9 days ago

I´m so sorry guys.

#8 Updated by JMC4789 8 days ago

Does this occur if you turn on interpreter? I have a feeling I know what's going on. It'll be really slow, but, it may work there and give us a clue.

#9 Updated by JMC4789 8 days ago

  • Status changed from New to Questionable

I tested this out - cannot reproduce the issue. Could be an issue with the macOS drivers... have you tried MoltenVK in the very latest development builds?

#10 Updated by Alberto 8 days ago

I was testing the game with the interpreter mode on and the characters still invisibles. I tested many graphics configurations. curiously if i swich on enable wireframe i can see the characters but obviously it´s unplayable in this way.

I've never heard before MoltenVK, i´ll search some information about it and i´ll try.
One more time sorry for my horrible English and thank you

#11 Updated by JMC4789 8 days ago

Select the Vulkan Backend in the latest Dolphin builds.

#12 Updated by Alberto 8 days ago

Yeah Man¡¡¡ with the Vulkan mode the game looks great. You are a genius , not like me jajaja

Do you recommended me to play all the games in vulkan mode or only for dragon ball revenge of king piccolo?

#13 Updated by Billiard26 2 days ago

  • Status changed from Questionable to Won't fix

Solved by using MoltenVK. Probably caused by OS X's poor support of Open GL.

Also available in: Atom PDF