Project

General

Profile

Emulator Issues #11481

Compiling with ENABLE_LTO prevents Qt GUI from loading

Added by madigens about 1 year ago. Updated 10 months ago.

Status:
Won't fix
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What's the problem? Describe what went wrong.

Compiling with GCC 8.2.1 on Fedora 29 x64 with Qt 5.11.1 and ENABLE_LTO makes the GUI not start, the following lines are printed on the console:

QObject::connect: signal not found in QSocketNotifier
QObject::connect: signal not found in QSocketNotifier
QObject::connect: signal not found in QDBusServiceWatcher

This did not happen on Fedora 28 with GCC 8.0.x.

What steps will reproduce the problem?

cmake -E remove_directory build && cmake -E make_directory build && cmake -E chdir build cmake -DENABLE_LTO=ON -G Ninja .. && cmake --build build --config Release

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Tested on git master (commit f510f6ef0d72764cae23a1c662ffdc92c45acd9e at time of writing).

Is the issue present in the latest stable version?

5.0 didn't have Qt iirc.

If the issue isn't present in the latest stable version, which is the first broken version?

I can only get 823fdda30c38be953c3d425874f2adeabed2b5a8 to compile on GCC 8.2.1. The GUI starts but is mangled, lots of "signal not found" error messages for a whole lot of controls.

What are your OS specifications?

Fedora 29 x64, GCC 8.2.1, Qt 5.11.1

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

Turning LTO off presents a usable GUI.

History

#1 Updated by delroth about 1 year ago

We know, and it's documented: https://github.com/dolphin-emu/dolphin/wiki/Building-With-Qt

Similar issues have been reported to Qt a few times: https://bugreports.qt.io/browse/QTBUG-61710 . They blame the compiler.

#2 Updated by madigens about 1 year ago

Interested in a PR that errors out the build process when both LTO and Qt are enabled?

#3 Updated by spycrab0 10 months ago

  • Status changed from New to Won't fix

FWIW not all compilers are affected.

Also available in: Atom PDF