Project

General

Profile

Emulator Issues #11497

Dolphin can no longer start on recent Windows builds because of Qt5. Does this means the Wxwidgets ᴜɪ will have to be brought back ?

Added by ytrezq over 1 year ago. Updated over 1 year ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Yesterday I decided to perform 2 updates : Dolphin (last time I updated Wxwidgets was still available) and Windows 10 Insider !

And it seems that with the strengthening of their Bug Bounty Program, Microsoft put an end to the trick of writing a modified system ᴅʟʟ inside directory from which the application loaded for hacking (since it allowed to override system ᴅʟʟ in System32) with recent Windows 10 builds (while I can’t tell exactly at which build the change was introduced I tested several builds and it seems this radical policy change was set in October).

Which means executables can no longer load ᴅʟʟs automatically from their directory because everything runs as if I would have deleted the Qt5 ᴅʟʟs in previous Windows version !
There’s an error message like this for each Qt Dll.

Of course, with administrator privileges, it’s still possible to copy the ᴅʟʟs to %systemroot%\System32 in order to get programs running with the old way which will works for most of the case. But Qt5 mains ᴅʟʟꜱ’s then can’t load required ᴅʟʟs from QtPlugins directory : how to fix this ?.

Compared with the latest version of WxWidget this year before removal (again on latests Windows build), there’s no problem at all since everything was either installed by default or statically linked or Dynamically loaded.

As result, I’m stuck at the lastest Wx Dolphin build.

History

#2 Updated by delroth over 1 year ago

No, the wx UI is not coming back. Unless you can point to an actual Windows behavior change regarding DLL search paths, I'll file this as user error. I'm not going to just go and believe MS decided to break compat with 20+ years of software without evidence.

#3 Updated by delroth over 1 year ago

  • Status changed from New to Invalid

#4 Updated by ytrezq over 1 year ago

Anyway the ᴅʟʟs are locked.

Also available in: Atom PDF