Project

General

Profile

Emulator Issues #11505

The Dog Island - Lag During Lens Flare Effect in Opening Cutscene

Added by enderghast13 over 1 year ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

The Dog Island

Game ID? (right click the game in the game list, properties, info tab)

RDIE41

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

USA: 6fa48e4883137a813312688ea7704032

What's the problem? Describe what went wrong.

In the opening cutscene of the game with the view of the island, emulation speed drops to about 80-40% depending on your video backend and graphics settings when the lens flare effect is being rendered. Lens flare effects are also being rendered incorrectly at other points in the cutscene.

What steps will reproduce the problem?

Start the game and skip past or watch through the company logos and song. After pressing A at the title screen, a cutscene showing a view of an island plays. A few seconds in, a lens flare effect shows while a dog is coming back from a ship, causing the emulation speed to drop. Lens flare effects also play at other points in the cutscene when they should not.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes in 5.0-9250 (commit bfb9b1aca54481af905877edc0fe950e9273d3b1)

Is the issue present in the latest stable version?

Yes in 5.0

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

Not applicable

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

https://mega.nz/#F!MB0A3AYa!R9P2nz4d3XIaNilciPRUUg <-- Here are two logs; 1.dff is the first occurrence; 2.dff is later when a lens flare is rendered when it should not be.
https://youtu.be/Kzyg3lyF9Mw?t=85 <-- This video shows what the cutscene should normally look like.

What are your PC specifications? (CPU, GPU, Operating System, more)

PC: Dell Inspiron 15 7559
CPU: Intel Core i7-6700HQ (2.6 GHz)
GPU: Nvidia GeForce GTX 960M (4 GB VRAM)
OS: Windows 10 Home x64 v.1803
RAM: 16GB DDR3L

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

None


Related issues

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by JosJuice over 1 year ago

Does enabling or disabling Skip EFB Access from CPU affect this?

#2 Updated by JMC4789 over 1 year ago

The lag I honestly couldn't care less about - EFB access lag happens, oh well. The incorrect rendering, however, I will look into tonight.

#3 Updated by JMC4789 over 1 year ago

  • Status changed from New to Duplicate

Cannot reproduce any serious slowdown or graphical issues - it matches the video perfectly for me. OpenGL, Windows 10, Single Core.

If I turn on dualcore I get the strange flickering, but, that's the same as Wind Waker's issue.

#4 Updated by JMC4789 over 1 year ago

#5 Updated by JosJuice over 1 year ago

And note that even if there is slowdown, we generally don't accept performance issues. Some effects just are extra demanding to emulate.

#6 Updated by JMC4789 over 1 year ago

I didn't see any major slowdown whatsoever on an i7-6700K though, it was 170 FPS without the effect, 150 FPS with the effect. You can turn on Skip EFB Access from CPU if you want to disable it in exchange for performance.

#7 Updated by enderghast13 over 1 year ago

Thank you for your suggestions. Disabling Dual Core mode did in fact solve both of my issues. Sorry about asking about a performance related issue.

#8 Updated by JMC4789 over 1 year ago

I mean, it's still good to know what causes slowdown, even if we usually don't keep performance related issues open.

Also available in: Atom PDF