Project

General

Profile

Emulator Issues #1152

Loading save-state causes Dolphin to think memory card is corrupt

Added by federelli almost 12 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

I start Z:WW and i can either load a savestate or load my savegame.
If i load the savegame everything's fine.
If i load the savestate, and then i try to save the game, i get a message
from the game, saying that the memory card is corrupt and the game cannot be
saved.

r3816 32b


Related issues

Has duplicate Emulator - Emulator Issues #1235: Save Error When Loading Save States (GC)Duplicate

Blocked by Emulator - Emulator Issues #1229: Corrupted Memcards after load state if you delete a save from memcard firstFixed

History

#1 Updated by federelli almost 12 years ago

Ugh this is hard to reproduce, and i accidentally overwrote the savestate that did that
:/

#2 Updated by lpfaint99 almost 12 years ago

I've heard of this happening before, ideally we could (like pcsx2) eject the memcard
before a savestate, and reload the memcard after a savestate

#3 Updated by federelli almost 12 years ago

I know this happens in GT4 in PCSX2, could also happen here.

#4 Updated by XTra.KrazzY almost 12 years ago

  • Status changed from New to Accepted

nono, this happened to me too.

:(

It's caused when the memcard is formatted and you save the game after loading a
savestate. It's a memory card problem. Even if you create a new save file and then
load state and save it won't work.

Sadly, I have no idea on how to solve this.

#5 Updated by marcus almost 12 years ago

issue 1235 has been merged into this issue.

#7 Updated by federelli almost 12 years ago

Xtra, new findings on this.

Check issue 1229.

#8 Updated by llsbackup over 11 years ago

Not sure if this helps, but if I load a game in ZWW and save, it's fine. If I save
using a save state, then immediately afterward try and save through the memory card,
it says corrupt. I don't necessarily have to load the save state for the error to
show up.

#9 Updated by lpfaint99 over 11 years ago

llsbac...@hotmail.com: that is due to r3999 which I will be reverting

#11 Updated by lpfaint99 over 11 years ago

  • Status changed from Accepted to Fixed

This issue was closed by revision r4913.

#12 Updated by Migs351 over 10 years ago

This is not fixed completely.... I still get this problem with Metroid Prime 2 (NTSC if that matters at all)

I'll save the state at a point to try and do a trick/sequence breaking glitch in the game (some of them are really tricky, so save states really help.) and then load it many times until I get the trick right or past that part or whatever, I then get to a save room and go to save and it says it can't find the memory card in slot a.

This is fixed by simply saving it right there using a save slot in dolphin, closing dolphin, re-opening and open the game, then load the save slot, and save normally... it's like it just loses the memory card info somehow when doing multiple save/loads...

#13 Updated by Anonymous over 10 years ago

does it actually corrupt the memcard for you? What if you manually eject/insert the memcard while the game is running? You could also manually eject the memcard before saving state, then insert it after loading state.

#14 Updated by Migs351 over 10 years ago

No, the memory card is fine, and I can save data to it like normal if I do what I said above, and all the other data is still there... It's just like it doesn't know where the memory card is anymore, as if you were playing the game on the real GC and pulled the memory card out in the middle of playing and then tried to save... I have not tried the eject/insert, I'll try that tonight.

Also available in: Atom PDF