Project

General

Profile

Emulator Issues #11537

Cannot update Dolphin with the integrated Updater

Added by Der_Siebte_Schatten over 3 years ago. Updated over 3 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What's the problem? Describe what went wrong.

When trying to update Dolphin with the intgrated updater, the update will instantly fail with the following error message:

"A fatal error occured and the updater cannot continue:
Could not fetch current manifest. Aborting."

What steps will reproduce the problem?

Update Dolphin with the integrated updater.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Cannot be tested, because a newer version is needed to launch the updater.
Last version tested: Build 5.0-9431

Is the issue present in the latest stable version?

No (not applicable)

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

All versions with updater seems broken. I went back trough the 9xxx builds and none worked, even if they worked before.

What are your PC specifications? (CPU, GPU, Operating System, more)

Intel Core i7-5600 HQ @ 2.7 GHz
Intel HD 5600 + NVidia GTX 970M
16 GB RAM
128 GB SSD + 1 TB HDD
Windows 10 Professional x64, Build 1809 (17763.292)

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

The issue happens on a german fixed connection, as well as on a french cellular connection. Alos, previous builds where the updater worked doesn't work anymore today.

History

#1 Updated by JMC4789 over 3 years ago

If the updater used to work, can you find out when it stopped working?

#2 Updated by JosJuice over 3 years ago

Wouldn't you need a time machine for that? ;)

#3 Updated by JMC4789 over 3 years ago

Last time it broke, jumping to an older build fixed it for some reason. That helped with narrowing down when the updater got borked.

#4 Updated by Der_Siebte_Schatten over 3 years ago

I tried with older 9xxx builds when doing a bisect. I went until the older 9xxx one without luck...

#5 Updated by JMC4789 over 3 years ago

Isn't there an updater log or something? There should be if it's failing.

#6 Updated by spycrab0 over 3 years ago

  • Assignee set to delroth
  • Status changed from New to Fix pending

Cause and solution is known. (our server needs the latest sadm commit).
It's entirely serverside, so there's no need to manually download anything.

#7 Updated by spycrab0 over 3 years ago

  • Status changed from Fix pending to Fixed

The issue has been resolved.

Also available in: Atom PDF