Project

General

Profile

Emulator Issues #11591

Super Paper Mario Door Animation Skip

Added by SKure27 over 1 year ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

[Super Paper Mario]

Game ID? (right click the game in the game list, properties, info tab)

[R8PE01 (0001000052385045)]

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

[ba74fb5b6b820b6feb771786180e4c65]

What's the problem? Describe what went wrong.

[When playing Super Paper Mario, if you change the internal resolution to output 1080p video. The Door animation is skipped. When traveling through the rainbow colored doors you continue to the next room and the door opening/closing sound plays but you just stand in front of the door. Mario disappears instead of walking thorough the door.]

What steps will reproduce the problem?

[I'm currently on chapter 1-2. In the area of the game where you get Thoreau. Walk up to one of the rainbow colored doors and try to enter.]

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

[Dolphin 5.0-9654]

Is the issue present in the latest stable version?

[Not Sure]

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

[First broken version number here (if applicable)]

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

[Attach any fifologs if possible, write a description of fifologs and screenshots here to assist people unfamiliar with the game.]

What are your PC specifications? (CPU, GPU, Operating System, more)

[Core I3 6100, GTX 1050 Mini, Windows 10 64 bit, 8gb Ram, 128gb SSD, 2Tb HDD]

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

[Anything else here]


Related issues

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by JMC4789 over 1 year ago

Bounding Box can be incredibly slow on higher resolutions and is one of the few things that can cause framerate desyncs in dualcore. Are you sure the game isn't just lagging so hard that it's skipping the bounding box door transition?

#2 Updated by JMC4789 over 1 year ago

  • Status changed from New to Duplicate

No response, going to assume dualcore issue.

#3 Updated by JMC4789 over 1 year ago

Also available in: Atom PDF