Project

General

Profile

Actions

Emulator Issues #1160

closed

enabling both ProfiledReJIT and Idle Skipping causes a crash

Added by bgtsetso over 14 years ago.

Status:
Won't fix
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?

  1. Tested on Resident Evil 1 (both GC and Wii versions) - sorry, I don't have other games that work with ProfiledReJIT
  2. Crash occurs just before it goes ingame 3.

What is the expected output? What do you see instead?

What version of the product are you using? On what operating system?
any rev

Please provide any additional information below.

Actions #1

Updated by marcus over 14 years ago

This is gonna sound real n00bish coming from a dev, but...

Where is the option for ProfiledReJIT?

Actions #2

Updated by bgtsetso over 14 years ago

:) you put it manually in the [Core] section of dolphin.ini. It is useful only for
the JITIL though.

Actions #3

Updated by marcus over 14 years ago

It appears the the IL build is currently broken (r3858)...

Actions #4

Updated by bgtsetso over 14 years ago

hm, it was working on 3856 (just ran a game on it and works)

Actions #5

Updated by marcus over 14 years ago

Shoot, I'll have to test that on Thursday...Going to Pennsylvania for the next few
days, won't be back till then. Sorry :(

Actions #6

Updated by bgtsetso over 14 years ago

:) that's ok

Actions #7

Updated by marcus over 14 years ago

Well, I can't get it to compile the IL build (even in r3856), so I can't test this.

Can someone else who can get the IL build to work test this please?

Actions #8

Updated by bgtsetso over 14 years ago

well, it compiles, you can get a build from the "Dolphin-emu SVN Builds" topic in the
forum.

Actions #9

Updated by marcus over 14 years ago

  • Status changed from New to Accepted

Right. Got it to work.

The problem is:
Segmentation Fault (code 0xc0000005) at address 0x9a98031.

Any idea where that is?

Actions #10

Updated by bgtsetso over 14 years ago

ahm, what do you mean?

Actions #11

Updated by marcus over 14 years ago

I mean that a pointer is being used incorrectly in the line of code that is mapped
to the machine instruction at address 0x9a98031.

Actions #12

Updated by LinesPrower over 14 years ago

  • Status changed from Accepted to Won't fix

ProfiledReJIT is a speedup hack which breaks most games. It can't be fixed. Just don't
use it.

Actions

Also available in: Atom PDF