Project

General

Profile

Emulator Issues #11609

Aspect ratio switching problem.

Added by Nikorasu081 over 1 year ago. Updated 3 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

[Multiple Games actually, however, i'm only going to show the games in bold. Animal Crossing, Pikmin 2, SoulCalibur II, Starfox Adventures, Melee, Brawl, Super Paper Mario etc. ]

Game ID? (right click the game in the game list, properties, info tab)

[GAFE01,GPVE01,GRSEAF,GSAE01,GALE01 RSBE01,R8PE01]

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

[Put MD5 Hash here]

What's the problem? Describe what went wrong.

[Dolphin emulator's 16:9 aspect ratio used to work perfectly until the code was changed. 16:9 games were all true 16:9 with no black bars on the side. Games also didn't rapidly switch aspect ratios on me when using a 16:9 AR code. The culprit for this issue is Dolphin 4.0-7138 "Aspect Ratio/VI Scaling Fix (PR #2765 from mirrorbender)" I confirmed this by testing 4.0-7135 the version before that one. With 4.0-7135 all Wii games correctly display 16:9 with no black bars on the side. All Gamecube games that are using a 16:9 code also display perfectly with no black bars on the side. Also, the issue where games couldn't make up their mind and would rapidly switch between 4:3 and 16:9 doesn't occur anymore either. I have uploaded 3 videos on YouTube showing the issue which is better than explaining it in text. The first 2 videos showcase the bug where Dolphin can't make up its mind and keeps rapidly switching between 4:3 and 16:9.

Video 1(Pikmin 2): https://www.youtube.com/watch?v=P17EzH-qhoM
Video 2(StarFox Adventures): https://www.youtube.com/watch?v=yHtrZdyH1yg

Last Video showcases how 4.0-7135 was able to display all games perfectly in 16:9 with no black bars and no issues.]
https://www.youtube.com/watch?v=RvAySOeDyEo&feature=youtu.be

What steps will reproduce the problem?

[Download the latest Dolphin version and old version 4.0-7138 and compare the way they display games in 16:9 versus the way 4.0-7135 correctly displays them. Please reference my video if needed.]

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

[5.0-9723]

Is the issue present in the latest stable version?

[Yes/No and version number here]

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

[4.0-7138]

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

[Attach any fifologs if possible, write a description of fifologs and screenshots here to assist people unfamiliar with the game.]

What are your PC specifications? (CPU, GPU, Operating System, more)

[Windows 10 Pro x64, Intel i7 9900K, GTX 2080 Ti, 16GB DDR4]

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

[The videos I uploaded to YouTube]


Related issues

Is duplicate of Emulator - Emulator Issues #9024: Add an option to override correct aspect ratio/enable square pixelsQuestionable

History

#1 Updated by JosJuice over 1 year ago

16:9 games were all true 16:9 with no black bars on the side.

That they are not true 16:9 is not a bug. If you measure the aspect ratio on a real TV (if you have a TV where none of the image gets hidden due to overscan), you will find that it isn't true 16:9. Dolphin emulates that correctly now. If you prefer to have the wrong aspect ratio and no black bars, like in 4.0, you can set the aspect ratio setting to "Stretch to Window".

Games also didn't rapidly switch aspect ratios on me when using a 16:9 AR code.

That the Auto aspect ratio option rapidly switches between aspect ratios is a bug. Issues 11235, 11243 and 10795 are existing reports of this, but I suppose I shouldn't mark this issue as a duplicate of any of those since this covers more games? Does the problem with rapidly switching aspect ratios happen in all of the games that you listed?

#2 Updated by Nikorasu081 over 1 year ago

JosJuice wrote:

That they are not true 16:9 is not a bug. If you measure the aspect ratio on a real TV (if you have a TV where none of the image gets hidden due to overscan), you will find that it isn't true 16:9. Dolphin emulates that correctly now. If you prefer to have the wrong aspect ratio and no black bars, like in 4.0, you can set the aspect ratio setting to "Stretch to Window".

I just find it so annoying because for each game that has black bars I have too add "[Video_Settings]
AspectRatio = 1 or 3" to the .ini for the game. I guess the reason the Wii wasn't true 16:9 is because a lot of people were still using 4:3 CRT's and having true 16:9 would just crop the information. Some games have more black bars than others like Super Paper Mario and it just looks so bad. Heck, even GameCube games that have a 16:9 option in game has black bars like Starfox Adventures and SoulCalibur II.

That the Auto aspect ratio option rapidly switches between aspect ratios is a bug. Issues 11235, 11243 and 10795 are existing reports of this, but I suppose I shouldn't mark this issue as a duplicate of any of those since this covers more games? Does the problem with rapidly switching aspect ratios happen in all of the games that you listed?

It does it for all the GameCube games I listed.

#3 Updated by JosJuice 3 months ago

  • Is duplicate of Emulator Issues #9024: Add an option to override correct aspect ratio/enable square pixels added

#4 Updated by JosJuice 3 months ago

  • Status changed from New to Duplicate

The problem with Dolphin inappropriately switching between 4:3 and 16:9 has been fixed by 5.0-11841. The other half of this issue is the same as issue 9024, so I'm marking this as a duplicate of that.

Also available in: Atom PDF