Project

General

Profile

Emulator Issues #11614

[FEATURE REQUEST] AI-based super-resolution upscaling (ESRGAN) for textures

Added by Jebeld17@gmail.com over 1 year ago. Updated over 1 year ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

I've removed the bug template on this issue, as it's a feature request rather than a standard bug report.


Using ESRGAN, users have been able to manually generate 4K-ready AI-trained texture packs to bring their old games into this generation, like this seen here: https://youtu.be/39xrl9z2ZZs

I'd love to see this kind of power given to all users alike using a built-in ESRGAN-based texture pack upscaling and super-resolution.

History

#1 Updated by JosJuice over 1 year ago

Would that really be fast enough to run in real time? If not, then there's not much reason to integrate it into Dolphin.

#2 Updated by MayImilae over 1 year ago

  • Status changed from New to Invalid

AI based upscaling requires training, which takes time and lots of computing power! And we can't ship training because it's illegal and would be enormous. So implementing it within Dolphin for real time use isn't practical. Besides, you can jump dump the textures, run them through an existing trained AI that is available online, and then use it as a texture pack!

Also available in: Atom PDF