Project

General

Profile

Emulator Issues #11629

Mario Kart Double Dash on Android glitches

Added by krux over 1 year ago. Updated about 2 months ago.

Status:
Questionable
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
Android
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game ID: GM4E01
Dolphin 5.0-9494

On a Galaxy S7 Android 8 device (Mali T880 according to webglreport) there are severe graphical glitches in OpenGL ES mode (on LSD).
I guess that's due to the known driver bugs which won't get fixed on old devices.
Also the audio is very distorted.

With the Vulkan renderer there are no such issues and it runs much faster.
Audio is thus less distorted but still to some extent when the emulation slows down.
The main issue is in-game there is a blue haze layer between the main image and the GUI, making it hard to see anything:
https://imgur.com/KgFyuJE

There are also temporary black boxes in the main menu after switching between menu items:
https://imgur.com/KffJdvA

The game works fine on a Windows machine.

History

#1 Updated by Stenzek over 1 year ago

The blue haze is because your device does not support dual-source blending in Vulkan. Doesn't look the latest drivers do, even. It's fine on Adreno.

Not sure what's going on with the black boxes.

#2 Updated by JosJuice over 1 year ago

  • Status changed from New to Questionable
  • Operating system Android added
  • Operating system deleted (N/A)

#3 Updated by krux over 1 year ago

Ok good to know, so that blue haze is a won't fix?!

#4 Updated by krux over 1 year ago

Ok good to know, so that blue haze is a won't fix?!

#5 Updated by krux over 1 year ago

Btw OpenGL looks like https://www.youtube.com/watch?v=wsjmCkS3DJk
And prints OpenGL ES 3.2 v1.r22p0-01rel0.​f294e54ceb2cb

#6 Updated by JosJuice over 1 year ago

Yes, the blue haze on Vulkan is a won't fix.

#7 Updated by ryanebola16 about 2 months ago

Can't reproduce the black boxes on 5.0-12734 so this is likely a graphics driver issue, although I tested with the NTSC-U version. I won't close this issue in case another dev has interest in fixing it though.

Samsung Galaxy Note8 (SM-N950U)
Qualcomm Snapdragon 835
Octa-core (4x2.35 GHz Kryo & 4x1.9 GHz Kryo)
Adreno 540
6GB RAM (LPDDR4)
Android 9
OpenGL ES 3.2 V@331.0

Also available in: Atom PDF