Project

General

Profile

Emulator Issues #11632

Tony Hawk's Pro Skater 3 CPU thread too fast crash

Added by xerxes 10 months ago. Updated 9 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Tony Hawk's Pro Skater 3

Game ID?
GT3E52

MD5 Hash?

8fd5510e28b32545f8f31c365e467e55

What's the problem? Describe what went wrong.

Randomly the game will crash with a "CPU thread too fast!" error. If you try and continue anyways, the window goes black and Dolphin crashes. This happened twice on the Canada stage skating past chuck towards the Canadian flag, and once switching characters from Tony Hawk to Rune Glifberg. The crashes were spread out by about 20-30 minutes each.

What steps will reproduce the problem?

Don't know a consistent way to reproduce. Just skate around on Canada and hope it happens.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes, 5.0-9795.

Is the issue present in the latest stable version?

Apparently not, I didn't have it happen when I played through the game once just now on 5.0, though I used Rune Glifberg instead of Tony Hawk. I tried Rune Glifberg since I thought the crash may be tied to the unlockable deck for Tony Hawk on Canada, since it was in frame on the first two crashes. (Tony Hawk and Rune Glifberg both have the same secret deck location.) I think it's a regression. I played the game on Dolphin way back on 4.0-4478 too and didn't have it crash then either.

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

Didn't bisect since it seems horrible as the crash happens randomly during play.

What are your PC specifications?

Intel Core i3-3220 @ 3.3GHz, NVIDIA GeForce GTX 1060, Windows 10


Related issues

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by JMC4789 10 months ago

Turn off dualcore. Just in general, that should fix all of these issues. If you didn't have it happen in x old build, you were lucky.

#2 Updated by JMC4789 9 months ago

  • Status changed from New to Duplicate

#3 Updated by JMC4789 9 months ago

Also available in: Atom PDF