Project

General

Profile

Emulator Issues #11648

Animal Crossing bad frame pacing

Added by xerxes about 2 years ago. Updated about 2 years ago.

Status:
New
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Animal Crossing

Game ID?

GAFE01

MD5 Hash?

7853049ccd0c1e2bffeb5b12393a5409 (confirmed with redump)

What's the problem? Describe what went wrong.

While staying at 60FPS/VPS, the game has slight framerate stuttering and hitching (I think frame pacing is the term for this?). I've tried single core, all the backends, v-sync, and sync/async ubershaders to no effect. No other games I have shows this kind of frame pacing issue.

What steps will reproduce the problem?

Let the intro "Press Start" screen play or do anything, it usually happens between acre transitions.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes, 5.0-9861.

Is the issue present in the latest stable version?

Yes, it happens in 5.0. I even had this happen wayyyyyyy back in the ancient past in 4.0-4163. (Same computer, just Linux and a GTX 650 instead.)

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

I caught a fifolog during the stutter (I think), I hope it helps.

What are your PC specifications?

Intel Core i3-3220 @ 3.3GHz, NVIDIA GeForce GTX 1060 driver 419.67, Windows 10

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

Attached fifolog.

ac-stutter.dff (1.99 MB) ac-stutter.dff xerxes, 03/30/2019 05:11 AM

History

#1 Updated by Techjar about 2 years ago

Seems fine here. Do you get any audio stutter or just video?

#2 Updated by xerxes about 2 years ago

Just video. And yes, I just tried ubershaders and async on the title screen and a little bit ingame (triggered Resetti, lol) and it still happens. I could record a video I guess and see if it shows through the recording if that would help. Audio sounds perfectly fine without any hitches at all while it happens.

#3 Updated by JMC4789 about 2 years ago

Do you have the game on a slow harddrive? Have you tried increasing the emulated CPU clock? Have you tried increasing audio variance (which is currently INI only.)

#4 Updated by JMC4789 about 2 years ago

fifolog won't show any kind of performance issue in regards to a slight stutter, it's purely a replay of GPU commands.

#5 Updated by xerxes about 2 years ago

In exclusive fullscreen with v-sync on to quell the screen tearing it's much, much less frequent, but it still happens for a fraction of a second once in awhile.

Can you teach me how/what is audio variance? FOR WINDOWED MODE: I tried 115% CPU and 400% CPU and it's exactly the same. It's on a 5400RPM HDD that I've been using nonstop for 5 or 6 years...

#6 Updated by xerxes about 2 years ago

Here's a video of it happening that I made. Make sure to watch in 720p60. Whenever I stop and walk back and forth over a spot is when stuttering happened for me too. https://www.youtube.com/watch?v=wtURwOX9yIM

#7 Updated by Techjar about 2 years ago

Do you have monitors with mixed refresh rates?

#8 Updated by xerxes about 2 years ago

No, just one standard 60Hz LED monitor. Never used dual monitors on this computer ever.

#9 Updated by xerxes about 2 years ago

Switched operating systems to Lubuntu 18.10 (nvidia-driver-390 drivers) and this game in particular has really horrible screen tearing now. With V-Sync on, it stutters verrrrry rarely but still does in a similar way to Windows in Exclusive Fullscreen mode. Tried Radirgy GeneriC as well and the frame pacing in that game was perfect. (I tried async precompiled ubershaders too because it was also having shader-type stuttering too which seemed to have gone away when I enabled it.)

#10 Updated by xerxes about 2 years ago

those results were in windowed mode, and I think it's DolphinQt that compiled.

Also available in: Atom PDF