Project

General

Profile

Emulator Issues #11660

Star Fox Assault boot problems

Added by Korados 10 months ago. Updated about 2 months ago.

Status:
New
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Star Fox Assault (PAL/Europe)

Game ID? (right click the game in the game list, properties, info tab)

[GF7P01]

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

d77a7aa0d0e3bf52572ce4b8251c1339

What's the problem? Describe what went wrong.

I'm on 5.0-9896 right now and wanted to play Star Fox Assault but the game doesn't boot.
I only get a black screen. I tried other backends and turning off FPRF but that didn't help.
All other games are working fine. So I used the bisect tool to track down the issue
and came up with two builds.

What steps will reproduce the problem?

Starting the game will either give an invalid write message or the game doesn't boot at all.

Is the issue present in the latest stable version?

No.

If the issue isn't present in the latest stable version, which is the first broken version?

Since 5.0-5874, Dolphin shows the error message "Invalid write to 0x01fe0202, PC=0x80130780" before booting the game.
Since 5.0-6568, the game doesn't boot at all and only shows a black screen.

History

#1 Updated by MayImilae 10 months ago

You did not list your system specifications, which is required. Please comment with your system specs below, or this issue will be closed.

#2 Updated by Korados 10 months ago

I apologise. I thought it might not be necessary because I assume that the issue doesn't stem from my PC itself. Here are my PC's specs:

Alienware 17 R1
Intel Core i7-4900 @ 2.80 GHz (4.00 GHz Turbo Boost)
32 GB RAM DDR3
NVidia GeForce GTX 765M @ 2GB VRAM

#3 Updated by JMC4789 10 months ago

I'll investigate this, I don't know who else would have Starfox PAL. Can you bisect to the exact build that broke it?

#4 Updated by JMC4789 10 months ago

Turn on immediately present XFB copies. Should fix the issue. Prexisting bug, just different defaults.

#5 Updated by Korados 10 months ago

I just tried immediately present XFB on 9002 but this didn't help. But I discovered something else: The build 6568 sets MMU as default.
When I deactivate it on 9002, the game boots again and works fine but still shows the error message I mentioned. So I guess the MMU might be the problem,
not the XFB.

By the way, I didn't encounter this issue with the NTSC-U version. It seems to apply to PAL only.

#6 Updated by Techjar 10 months ago

The game is accessing invalid memory, therefore it crashes with MMU on due to exceptions being emulated. It works with MMU off because the invalid memory access just so happens to be non-fatal in this case.

#7 Updated by JMC4789 10 months ago

There's a bunch of PAL games that have this kind of issue. Better GPU timings will fix it.

#8 Updated by Korados 10 months ago

What do you mean with better GPU timings?

#9 Updated by eckso 8 months ago

Korados wrote:

What do you mean with better GPU timings?

I think "SyncGPU = true", it worked for me.

#10 Updated by Korados about 2 months ago

Just for the protocol: This issue seems to be solved by itself. I don't know which revision fixed it but on 5.0-11325 it's perfectly fine.

Also available in: Atom PDF