Project

General

Profile

Emulator Issues #11663

SpongeBob SquarePants: Revenge of the Flying Dutchman - Model Corruption in Dual Core mode

Added by RibShark 10 months ago. Updated 9 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
SpongeBob SquarePants: Revenge of the Flying Dutchman

Game ID? (right click the game in the game list, properties, info tab)
GSQE78

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)
30b0601c43c4ee30b7498427c2aa70f5 (matches Redump.org)

What's the problem? Describe what went wrong.
When Dual Core mode is enabled, various models will be incorrectly rendered. This happens regardless of graphic settings. See screenshot below:

Intro logos also play at a lower framerate with dual-core.

Setting determenistic dual-core to Auto in the per-game settings fixes the issue.

What steps will reproduce the problem?
Start game with Dual Core mode enabled.
After the title screen, model corruption should be apparent.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.
Yes, 5.0-9910

Is the issue present in the latest stable version?
Yes, 5.0. (Intro movies are not affected in stable)

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer
FifoLog+Screenshot attached (in ZIP)

What are your PC specifications? (CPU, GPU, Operating System, more)
Windows 10 x64 17763
Intel i5 4690
NVIDIA GTX 970

FifoLog.zip (4.18 MB) FifoLog.zip FifoLog and Screenshot RibShark, 04/06/2019 05:09 PM

Related issues

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by JMC4789 10 months ago

That's the cost of using dualcore for performance. In games that are more strict with timing, things break :)

#2 Updated by JMC4789 9 months ago

  • Status changed from New to Duplicate

#3 Updated by JMC4789 9 months ago

Also available in: Atom PDF