Project

General

Profile

Emulator Issues #11694

CSI: Hard Evidence freezes before title screen when using interpreter

Added by JosJuice 4 months ago. Updated 4 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

CSI: Hard Evidence

Game ID? (right click the game in the game list, Properties, Info tab)

RCIP41

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

7794b556f3fadff8be6fcdde4128dc78

What's the problem? Describe what went wrong.

The game freezes during one of the pre-rendered videos that are shown before the title screen.

Please note that this problem was fixed for all CPU emulation engines other than interpreter by 5.0-10039 (which added a new form of idle detection for all CPU emulation engines other than interpreter).

This issue is not to be confused with issue 11580, which is about the game failing to even reach the Wii Remote warning screen when using the x64 JIT. That was also fixed by 5.0-10039.

What steps will reproduce the problem?

  1. Set the CPU emulation engine to interpreter. (Not cached interpreter.)
  2. Launch the game.
  3. Wait for something like 5 or 10 minutes to reach the Wii Remote warning screen.
  4. Press A.
  5. Wait even more and see if it freezes. No further button presses are needed. If you reach the title screen (with selectable options like "New Game" and so on), the bug is fixed. I'd estimate it would take something like an hour to reach the title screen, though.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes, 5.0-10039

Is the issue present in the latest stable version?

Yes, 5.0

What are your PC specifications? (CPU, GPU, Operating System, more)

Windows 10 x64
Intel Core i5-7300HQ (2.50 GHz)
Nvidia GTX 1050 (2 GiB)
8 GiB RAM


Related issues

Is duplicate of Emulator - Emulator Issues #11330: Dolphin's Emulated CPU is Too Slow/Fast in Various SituationsNew

History

#1 Updated by JosJuice 4 months ago

Works with 109% CPU clock but not 106% CPU clock. (Tested by disabling idle skipping and using the x64 JIT.)

#2 Updated by JosJuice 4 months ago

#3 Updated by JosJuice 4 months ago

  • Status changed from New to Duplicate

Also available in: Atom PDF