Project

General

Profile

Emulator Issues #11726

GameCube Games aren't properly informed about disc removal

Added by Luis over 1 year ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

GameCube Games, not Wii Games

What's the problem? Describe what went wrong.

When a GameCube game is running and the disc gets ejected, the game won't be properly informed about this. This results in the game trying to read data that isn't available which causes the game to crash. On real hardware the game displays a warning massage instead of crashing.

What steps will reproduce the problem?

  1. Start a GameCube game
  2. Press the hotkey to eject the disc.
  3. Continue to play the game until it wants to read data again.

Expected: A massage about a open disc cover is being displayed.
Acutal result: The game crashes.

Is the issue present in the latest development version?

Yes, 5.0-10121.

Is the issue present in the latest stable version?

No, because there is no option to eject the disc. (Version 5.0)

If the issue isn't present in the latest stable version, which is the first broken version?

5.0-5551 (Implementation of the eject disc function)

What are your PC specifications? (CPU, GPU, Operating System, more)

CPU: Intel Core i7-8700K @ 4,3 GHz
GPU: Nvidia GeForce GTX 980 [Zotac AMP! Edition]
OS: Windows 10.0.17134.706

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

I tested the GameCube games Mario Party 4 and Super Mario Sunshine - Both crash or hang and the Wii games Mario Party 9 and Mario Kart Wii - Both behave as expected (displaying a message).


Related issues

Is duplicate of Emulator - Emulator Issues #9019: Change Disc doesn't properly notify games about the disc changeFixed

History

#1 Updated by JosJuice over 1 year ago

  • Is duplicate of Emulator Issues #9019: Change Disc doesn't properly notify games about the disc change added

#2 Updated by JosJuice over 1 year ago

  • Status changed from New to Duplicate

Also available in: Atom PDF