Project

General

Profile

Emulator Issues #11738

It seems to be a major memory leak

Added by IlyaPlatonov 8 months ago. Updated 7 months ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

All the titles i have tried (MarioParty7, TLOZ:Twilight Princess, TLOZ: Skyward Sword, Xenoblade Chronicles).
So i think the leak is universal.

Game ID? (right click the game in the game list, Properties, Info tab)

many

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

many

What's the problem? Describe what went wrong.

During the playing memory having been devoured at rather constant rate (up to 180Gb on my computer till the complete stop).

What steps will reproduce the problem?

Just play the game for some prolonged time (say, a couple of hours).

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

5.0-10222 and some previous

Is the issue present in the latest stable version?

I don't tested that

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

Don't know

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

[Attach any fifologs if possible, write a description of fifologs and screenshots here to assist people unfamiliar with the game.]

What are your PC specifications? (CPU, GPU, Operating System, more)

Model Name: MacBook Pro
Model Identifier: MacBookPro8,1
Processor Name: Intel Core i7
Processor Speed: 2.7 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache (per Core): 256 KB
L3 Cache: 4 MB
Memory: 16 GB
External GPU (AKiTiO Thunder 2 Box): NVIDIA GeForce GTX 970 4095 MB

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

Vulkan renderer
Asynchronous Ubershaders
Screenshot of out-of-memory situation is attached.

History

#1 Updated by IlyaPlatonov 8 months ago

Mac os X 10.13.6 (17G6030)
NVidia Web driver 387.10.10.10.40.127

#2 Updated by spycrab0 8 months ago

Please fill out the bug report form properly and bisect.

#3 Updated by jpapetti0713 8 months ago

Questions:
1. Was pre-compiling shaders turned on?
2. What video resolution was the emulation set to?
3. Have you tried 5.0-10321 to see if the problem still exists?

#4 Updated by IlyaPlatonov 8 months ago

  1. I tested this with Synchronous and Asynchronous (Ubershaders), Pre-compiling was off in both cases.
  2. Resolution was 3x (1920x1584).
  3. Not tried yet.

#5 Updated by Stenzek 8 months ago

Does the leak also occur with OpenGL? There's mention of a leak fix in the latest MoltenVK release notes.

Also please note that we do not formally support Vulkan (MoltenVK) under macOS 10.13, only 10.14+, as it is missing some functionality we make use of. It might still work, however.

#6 Updated by IlyaPlatonov 8 months ago

Memory leaks with Vulkan only!
With OpenGL there is constant memory usage level of about 1Gb.

#7 Updated by IlyaPlatonov 8 months ago

Most recent MoltenVK dylib solved the problem. Thank you for advise.
I think it makes sense to update libvulkan.dylib in Dolphin releases from time to time. Not all users are able to build it themselves from sources.

#8 Updated by Maarcis12 8 months ago

7449

Yeah, i seemed to experience the same memory leak issues with build 10375, when suddenly it started eat up 8 GB of memory when using Vulkan, almost 2 GB when using Direct3D11 and OpenGL just straight up refusing to work. I'm using Windows 7 with Intel Core i3 4160, GTX 1050Ti Zotac OC Edition and 16 GB RAM.

#9 Updated by Techjar 8 months ago

That must be a different issue entirely, as the leak mentioned here is only applicable to MacOS.

#10 Updated by Maarcis12 8 months ago

Fair nuff, tho i thought to at least point it out. And the headline didn't specify the target.

#11 Updated by Pizuz 7 months ago

#12 Updated by JosJuice 7 months ago

  • Status changed from New to Fixed

Marking as fixed, then.

Also available in: Atom PDF