Project

General

Profile

Emulator Issues #11748

[FEATURE REQUEST] Resolution threshold for optimized performance

Added by Jebeld17@gmail.com 8 months ago. Updated 8 months ago.

Status:
Won't fix
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Feature request
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

I would love to see an addition into Dolphin that optimizes performance by setting what I'd like to call a "resolution threshold" - a maximum and minimum resolution that the game is allowed to drift between based off shader performance and FPS. The resolution of the game would attempt to hit the highest level possible as long as it remains a steady 60 FPS rate, tuning down to a lower resolution if the game performance is stuttering or the emulator is expecting poor shader performance.

This can be used in tandem with Ubershaders and other optimizations to give users the most fluid experience possible.

History

#1 Updated by Techjar 8 months ago

Changing the internal resolution invalidates the texture cache, which can break certain effects in games or cause high resolution effects to suddenly become low resolution, so this probably isn't a good idea. On top of that, I think this would only benefit low-end or very old GPUs, as most recent GPUs will run Dolphin without so much as breaking a sweat at typical resolutions, or even 4K in many cases.

#2 Updated by Billiard26 8 months ago

  • Status changed from New to Questionable

I'd vote against this. Like Techjar mentioned, this would cause problems with some games and even ignoring that, a dynamically changing resolution based on performance would be just strange and I'm not aware of any software that does this.

#3 Updated by JosJuice 8 months ago

  • Issue type changed from Bug to Feature request

A dynamically changing resolution based on performance is pretty common in modern games. But apart from the problems already mentioned, Dolphin doesn't support fractional IR scales, so the usefulness of such a feature would be a lot more limited than in modern games.

#4 Updated by Techjar 8 months ago

It's mostly seen in console titles, not much in PC titles. But yeah, without fractional IRs it would be rather limited, and the jumps in resolution would be quite obvious and jarring. We won't support fractional IRs as they cause nasty issues, which is why they were removed in the first place.

#5 Updated by Jebeld17@gmail.com 8 months ago

Even though it may break gameplay, many of the other graphic settings and features can break gameplay as well. I think it would be great to have as an option for users, with the same disclaimer on this feature that other features have.

#6 Updated by Techjar 8 months ago

Usually, settings that break graphical effects are forced via GameINI anyways. The major problem is changing these settings while the game is running. Besides, as stated, the wide gap between resolutions severely limits the usefulness of this, and would probably be pretty jarring to the experience. As such, I'm also voting against this.

#7 Updated by Helios 8 months ago

Jebeld17@gmail.com wrote:

Even though it may break gameplay, many of the other graphic settings and features can break gameplay as well. I think it would be great to have as an option for users, with the same disclaimer on this feature that other features have.

Also against this for the most part.

In my experience Dolphin users don't read what is presented to them based on forum support over time. Considering this is a feature that hurts waaaay more than it helps, since most GPUs aren't resolution limited on Dolphin (and thus this wouldn't even help much), I think this would be a pretty harmful feature to implement.

#8 Updated by JosJuice 8 months ago

  • Status changed from Questionable to Won't fix

Also available in: Atom PDF