Project

General

Profile

Emulator Issues #11750

Skyward Sword - Emulated Wii Remote MotionPlus - Spurious Stabs and Shield Bashing

Added by Exodus96 8 months ago. Updated 7 months ago.

Status:
Accepted
Priority:
Normal
Assignee:
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

The Legend of Zelda: Skyward Sword

Game ID? (right click the game in the game list, Properties, Info tab)

SOUE01

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

[Put MD5 Hash here]

What's the problem? Describe what went wrong.

In relation to emulated motion plus, Skyward Sword tends to 'stab after swings' and 'shield bash while tilting right analog stick', a behavior which is actually 'achievable' on console probably due to the creation of tons of acceleration data over a very small distances.

What steps will reproduce the problem?

Moving either of the analog stick (in terms of emulated swing of nun chuck and emulated swing of wii mote) can easily reproduce this problem.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

5.0-10411

Is the issue present in the latest stable version?

I believe as of now there's still no emulated motion plus in the latest stable version?

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

[Attach any fifologs if possible, write a description of fifologs and screenshots here to assist people unfamiliar with the game.]

What are your PC specifications? (CPU, GPU, Operating System, more)

i7-7700k, GTX 1080, Win10

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

[Anything else here]

History

#1 Updated by JMC4789 8 months ago

  • Assignee set to Billiard26
  • Status changed from New to Accepted

#2 Updated by Billiard26 8 months ago

  • Subject changed from Skyward Sword - stab after swinging and constant 'shield bash' while running to Skyward Sword - Emulated Wii Remote MotionPlus - Spurious Stabs and Shield Bashing

You're right about "tons of acceleration data over a very small distance" being the culprit.

The shoddy pseudo-physics engine that simulates the swings handles small movements poorly and produces higher than desirable acceleration values.

#3 Updated by Exodus96 8 months ago

Billiard26 wrote:

You're right about "tons of acceleration data over a very small distance" being the culprit.

The shoddy pseudo-physics engine that simulates the swings handles small movements poorly and produces higher than desirable acceleration values.

Hi just trying to check in and see if there's any update on this issue. :)

#4 Updated by Exodus96 7 months ago

Billiard26 wrote:

You're right about "tons of acceleration data over a very small distance" being the culprit.

The shoddy pseudo-physics engine that simulates the swings handles small movements poorly and produces higher than desirable acceleration values.

Hi - any update on this issue? :)

#5 Updated by Billiard26 7 months ago

You'll see updates here when there are any.

Also available in: Atom PDF