Project

General

Profile

Actions

Emulator Issues #11764

closed

(Suggestion/Bug) MacOS - Unsupported Metal Warning (Pre-Mojave) -- Does not play game, even when user acknowledges warning.

Added by jpapetti0713 over 4 years ago. Updated over 1 year ago.

Status:
Won't fix
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

I understand that there should be no bug reports regarding pre-Mojave, however, when using panic alerts for the Unsupported Metal warning, not one game will launch.
Before 5.0-10451, games were able to launch. Now, games would not even load.
Instead of using panic alerts, I would instead use an OSD Notification displayed for 60 seconds.
With OSD, the game will now launch.
I have created a pull request that uses the OSD fix, and will be uploaded soon

Game Name?

ANY

Game ID? (right click the game in the game list, Properties, Info tab)

ANY

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

ANY

What's the problem? Describe what went wrong.

Pre-Mojave will display Panic Alert with Warning that Metal is unsupported, clicking either button will not render the game.

What steps will reproduce the problem?

  1. Use Vulcan Backend
  2. Run game
  3. Click either option.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes, 5.0-4097

Is the issue present in the latest stable version?

N/A

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

5.0-10451

What are your PC specifications? (CPU, GPU, Operating System, more)

MacBook Pro (Retina, 13-inch, Mid 2014), 2.6 GHz Intel Core i5, RAM: 16 GB 1600 MHz DDR3, Video: Intel Iris 1536 MB, running MacOS High Sierra 10.13.6 (17G5019).

Actions #1

Updated by Techjar over 4 years ago

This panic alert doesn't check the result at all, so I don't see how it could be causing a crash. There must be some shenanigans going on here. Try some obvious things like disabling dual core. If an unchecked panic alert is causing crashes we'd like to figure out why.

Actions #2

Updated by Techjar over 4 years ago

Additionally, I'm not able to reproduce this behavior by modifying the code to display the panic alert regardless. That's on Linux though, so it could be a weird mac-OS-specific Qt issue.

Actions #3

Updated by jpapetti0713 over 4 years ago

Disabling Duel Core, Panic Handlers and Changing the emulation engine does not help.

I will post a screencap in the next post.

Now posted on Github
Github: http://dolp.in/pr8181

Actions #5

Updated by Techjar over 4 years ago

I still can't reason why that would be happening. Maybe it's a weird interaction with Apple's Intel Iris graphics driver, as VinDuv cannot reproduce it on NVIDIA.

Actions #6

Updated by JMC4789 over 1 year ago

  • Status changed from New to Won't fix

We no longer support pre-mojave

Actions #7

Updated by TellowKrinkle over 1 year ago

Side note, why does anyone want to leave their Mac on High Sierra? I can understand not upgrading because your Mac isn't officially supported on Mojave, but all Metal-supporting Macs can officially run Mojave, so that can't be the issue here.

Actions

Also available in: Atom PDF