Project

General

Profile

Emulator Issues #11779

[Linux] DolphinBar Is Not Reconized As A Device

Added by trymeout about 1 year ago. Updated about 1 year ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

I have a DolphinBar that I got from Amazon years ago and has always worked on Windows. I now using Linux Mint 19.1 and the DolphinBar is not recognized as a device in the Dolphin Emulator. I downloaded Dolphin through the Linux Mint Software Repo and it is version 5.0. I also tried copying the code in the Github link and naming it into a file and naming the file "51-usb-device.rules" and saving it into my "/etc/udev/rules.d/" directory but still nothing.

https://github.com/dolphin-emu/dolphin/blob/master/Data/51-usb-device.rules

History

#1 Updated by JMC4789 about 1 year ago

I'm pretty sure the DolphinBar only lists itself as compatible with Windows and macOS in the product description.

If you want to write your own driver for it, it'd work, but it's not a generic bluetooth device that'll just "work."

#2 Updated by JMC4789 about 1 year ago

Apparently I'm mistaken and it can work in Linux, ignore me. Someone else who's gotten it working in Linux will need to handle this.

#3 Updated by JosJuice about 1 year ago

  • Status changed from New to Invalid

5.0 does not support the DolphinBar on Linux. You need to update to a development version of Dolphin.

#4 Updated by trymeout about 1 year ago

I download the latest version using these commands

sudo apt-add-repository ppa:dolphin-emu/ppa
sudo apt update
sudo apt install dolphin-emu-master

But I have a new problem which is that when I load a game an error message appears saying...

Warning

Failed to initialize video backend!

I even tried to change the Graphics settings but nothing seems to work. However when I tried to configure my Wiimote, I clicked the Refresh button in the controller settings and tapped A & B on my Wiimote and I felt it vibrate for a second which makes me believe the Dolphinbar is working on the latest Dev build. But I am unable to launch a game to test it to confirm that it is working.

#5 Updated by Techjar about 1 year ago

That would be a separate issue, so please open a new one and fill out the template following the instructions in it.

#6 Updated by Helios about 1 year ago

Please don't. The issue tracker is not a support forum. Please use the forums for that.

#7 Updated by JosJuice about 1 year ago

Yes, please use the forums instead.

#8 Updated by trymeout about 1 year ago

https://forums.dolphin-emu.org/Thread-linux-failed-to-initialize-video-backend

Once I get this backend issue resolved I will report back on weather the latest Dolphin development version fixed this issue.

#9 Updated by trymeout about 1 year ago

OK I solved mt backend issue by changing my Graphics drivers to the open source drivers and the Dolphinbar does work with the latest build.

Also available in: Atom PDF