Project

General

Profile

Emulator Issues #11782

New Super Mario Bros. Wii ground disappearing at 2x resolution

Added by Waverick 6 months ago. Updated 5 months ago.

Status:
Accepted
Priority:
Normal
Assignee:
% Done:

0%

Operating system:
OS X
Issue type:
Bug
Milestone:
Current
Regression:
Yes
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name

New Super Mario Bros. Wii, New Super Mario Bros. Wii 2: The Next Levels, and Newer Super Mario Bros. Wii

Game ID

SMNE01, PPNE01, SMNE03 respectively

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

2619c1d81cd0292e0f272f9c06e48698, 0e2dc4d890623892752a72dbd720cffd, bc4181e9bbb0e118899ff02895dc6728 respectively

What's the problem? Describe what went wrong.

I set the resolution to 2x Native in the graphics settings menu and the ground disappeared, and came back when I changed the resolution in NSMBW and NSMBW2:TNL, but not NewerSMBW. I updated, and that made it so that it doesn't come back until the ground is rendered again (e.g. showing hint movie or "Princess Peach's Birthday" scene, then back to main menu)

What steps will reproduce the problem?

Open a level, any level, and set the resolution to 2x. It also happens in the main menu.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

5.0-10566

Is the issue present in the latest stable version?

No (5.0)

If the issue isn't present in the latest stable version, which is the first broken version?

I'm on Mac and can't use the bisection tool

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

screenshot attached

What are your PC specifications? (CPU, GPU, Operating System, more)

Mac OS X

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

not that I'm aware of

History

#2 Updated by Techjar 6 months ago

Does this also occur when using the Vulkan backend?

#3 Updated by Waverick 6 months ago

Techjar wrote:

Does this also occur when using the Vulkan backend?

It does not. I also found that it does not happen on the software renderer.

#4 Updated by JosJuice 6 months ago

  • Regression changed from No to Yes
  • Milestone set to Current
  • Subject changed from Ground disappearing at 2x resolution to New Super Mario Bros. Wii ground disappearing at 2x resolution
  • Operating system OS X added
  • Operating system deleted (N/A)

#5 Updated by JMC4789 5 months ago

  • Assignee set to Stenzek
  • Status changed from New to Accepted

I believe Paletted EFB Copies are broken on macOS OpenGL, which is why this is happening.

Also available in: Atom PDF