Project

General

Profile

Emulator Issues #11791

Castlevania III wrong framerate

Added by Miksel12 3 months ago. Updated 2 months ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Castlevania III: Dracula's curse, PAL

Game ID? (right click the game in the game list, Properties, Info tab)

FEQP01

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

9e8d7b6084a989c22c8268507941adff

What's the problem? Describe what went wrong.

The game will randomly drop to a framerate of 40-44FPS, this will stay this way until the framerate is unlocked and then locked again after which it will return to 50FPS. After around 30 second the framerate will drop again. If the framerate isn't unlocked, the game will stay at 40-45FPS for the whole game (or atleast for 10 min from testing). Tried with single core, LLE audio.

The game doesn't support 60FPS so I couldn't test that.

What steps will reproduce the problem?

Play the PAL version.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

5.0-10603

Is the issue present in the latest stable version?

No, I had no issues with 5.0.

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

I currently don't have time to bisect. Will bisect later.

What are your PC specifications? (CPU, GPU, Operating System, more)

i5 4670K @4.3GHz, GTX 1060, W10

History

#1 Updated by JMC4789 2 months ago

This game is actually somewhat demanding due to how it uses the texture cache. Is it possible you're just lagging due to vsync and unlocking the framerate disables vsync and allows it to recover? There's no enough information in this report for me to recommend or think of anything else.

#2 Updated by Miksel12 2 months ago

Vsync was disabled and the framerate uncapped was 280FPS so I don't think that is the problem.
The thing is that I can't seem to reproduce it on my laptop. I'll retest tomorrow when I have access to my pc.

#3 Updated by JMC4789 2 months ago

Alright, keep me updated. I'm unable to reproduce this issue, unfortunately.

#4 Updated by Miksel12 2 months ago

Ok, I've done goofed. I was experimenting with timingvariance and forgot to leave it at a reasonable value and I was using a portable config for 5.0 :P.
This can be marked as invalid, sorry.

#5 Updated by JosJuice 2 months ago

  • Status changed from New to Invalid

Also available in: Atom PDF