Project

General

Profile

Emulator Issues #11803

System menu does not notice disc changes that happen when it isn't open

Added by pokechu22 over 1 year ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What's the problem? Describe what went wrong.

The system menu seems to not notice disc changes if they happen while it is not open. On console, the system menu somehow knows the disc has been changed and starts reading it when it is returned to, but this does not happen in Dolphin.

What steps will reproduce the problem?

Change disc method (I prefer this since it's clearer what the channel is seeing):

  1. Load the system menu from the tools menu
  2. Observe that the disc channel reports that there is no disc inserted
  3. Select a game (I used Super Mario Galaxy), right click it, and select "Change Disc"
  4. Observe that the disc channel reports that that game was inserted
  5. Launch a different channel (I used the Mii Channel)
  6. Select a different game (I used New Super Mario Bros. Wii), right click it, and select "Change Disc"
  7. Return to the system menu (I did this using the return button in the Mii Channel)
  8. Observe that the disc channel still reports the game that was inserted in step 3, despite it being changed
  9. Attempt to start the game using the disc channel
  10. The system menu will reset, and then search for a disc (eventually determining that it is the disc from step 6 that is actually inserted). Launching via the disc channel will then work correctly

Direct launch method (a bit more opaque):

  1. Launch a game by double-clicking it (I used Mario Kart Wii to ensure that it is different from the ones used before)
  2. Return to the system menu from the HOME menu.
  3. Observe that the disc channel indicates a different game from the one you double-clicked (hopefully; this part is less consistent)
  4. Attempt to start the game using the disc channel
  5. The system menu will reset, and then search for a disc (eventually determining that it is the disc from step 1 that is actually inserted). Launching via the disc channel will then work correctly

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes; I am testing with 10648.

Is the issue present in the latest stable version?

Yes, this is also present in 5.0.

What are your PC specifications?

  • CPU: AMD A6-340M APU with Radeon(tm) Graphics, 1500 Mhz, 4 Core(s), 4 Logical Processor(s)
  • GPU: AMD Radeon HD 6520G
  • OS: Windows 10 Pro (Insider preview) 10.10.18362 Build 18362

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

Log file, hopefully with everything pertinent enabled, using the change disc method: log file

Some approximate timestamps of events of interesting:

  • 01:51 Changed disc to SMG
  • 02:20 Started Mii Channel
  • 02:42 Changed disc to NMBW
  • 02:27 Returned to Wii Menu
  • 03:06 Attempted to launch SMG; it reset

Related issues

Is duplicate of Emulator - Emulator Issues #8115: Disc Channel displays wrong game if the disc is changed when emulation is not runningFixed

History

#1 Updated by JosJuice over 1 year ago

  • Is duplicate of Emulator Issues #8115: Disc Channel displays wrong game if the disc is changed when emulation is not running added

#2 Updated by JosJuice over 1 year ago

  • Status changed from New to Duplicate

Also available in: Atom PDF