Project

General

Profile

Emulator Issues #11817

Kirby Air Ride unplayable with Vulkan on macOS

Added by Kuriibo over 1 year ago. Updated 7 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Kirby Air Ride

Game ID? (right click the game in the game list, Properties, Info tab)

GKYE01

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

ae4f3323a86c2397f31b33dd0ed0298b

What's the problem? Describe what went wrong.

When using Vulkan as the backend on macOS, the course/background/scenery textures don't load, while the characters and user interface appear correctly.

What steps will reproduce the problem?

The issue will become apparent upon entering a race

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

yes, 5.0-10762

Specifications:

2.4Ghz Core i5, Iris Plus Graphics 655, MacOS 10.14.6

KAR.mov (2.96 MB) KAR.mov Kuriibo, 08/04/2019 11:02 PM

Related issues

Related to Emulator - Emulator Issues #12247: Kirby Air Ride on Android: Black TexturesDuplicate

Is duplicate of Emulator - Emulator Issues #11843: Devices without LogicOps support render environment textures in Air Ride and City Trial as blackAccepted

History

#1 Updated by Anonymous 10 months ago

This issue also occurs on Android on my Nubia RedMagic 5g on Dolphin 5.0-12247. It appears exactly as the attached video in the OP, where most of the terrain is colored black. I'm not sure which graphics API is being used on my device.

Also worth noting, this only appears in the Air Ride and City Trial modes. The menu, opening cutscene, movies, and Top Ride all appear to render normally. The games Super Mario Sunshine and Pacman World 2 also appear to render normally.

#2 Updated by Wumbo 7 months ago

After some testing on my Galaxy S9 (android) I have found that the textures fail to load when upgrading from:

Dolphin version 5.0-10756 to 5.0-10758.

My device: Galaxy Note 9. snapdragon 845

#3 Updated by JosJuice 7 months ago

#4 Updated by JMC4789 7 months ago

  • Status changed from New to Duplicate

#5 Updated by JMC4789 7 months ago

  • Is duplicate of Emulator Issues #11843: Devices without LogicOps support render environment textures in Air Ride and City Trial as black added

Also available in: Atom PDF