Project

General

Profile

Emulator Issues #11825

[Android] Emulation hangs when app loses focus

Added by MrMrMANGOMILK 12 months ago. Updated 4 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
Android
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

[N/A]

Game ID? (right click the game in the game list, Properties, Info tab)

[N/A]

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

[N/A]

What's the problem? Describe what went wrong.

Exiting the app to the home screen or another app, or locking the device, causes the emulator to lock up, becoming unresponsive and forcing the user to close and reopen the app. This behavior does not occur unless a game is running.

What steps will reproduce the problem?

Launch any game and either open the Recents menu, press the Home button, or lock the device. Then either open the app again or unlock the device.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes, version 5.0-10883

Is the issue present in the latest stable version?

No, version 5.0

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

Unknown, appears to be 5.0-10669

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

[N/A]

What are your PC specifications? (CPU, GPU, Operating System, more)

Samsung Galaxy S9 Plus (Snapdragon 845 model), Android 9 with One UI 1

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

[N/A]


Related issues

Is duplicate of Emulator - Emulator Issues #12040: Dolphin Android crashes on savestate when using Vulkan (AbstractTextureFormat assert fails)Fixed

History

#1 Updated by MrMrMANGOMILK 9 months ago

Bumping this as it has not been addressed since the issue was added three months ago. The behavior is slightly different now, but is functionally the same as of version 5.0-11109 (you can get back into the app and the controls show up, but they're not correctly aligned on an 18.5:9 screen and nothing is actually functioning).

#2 Updated by JosJuice 9 months ago

  • Operating system Android added
  • Operating system deleted (N/A)

Could you test 5.0-11125 or later? There were some changes made in that version which might affect this.

For what it's worth, I can't reproduce the issue on my phone (Nexus 5X with Android 8.1.0), but I can't draw any conclusions from that since there's several things that can be different between phones that can affect the behavior.

#3 Updated by MrMrMANGOMILK 9 months ago

Behavior has actually changed as of 5.0-11153, it's now just crashing the app outright.

#4 Updated by JosJuice 9 months ago

Hm, that's not good... But on the other hand, it means it'll be easier to get a stack trace that shows us where the problem is. Since I can't reproduce it myself and I'm not sure if there's anyone else on the dev team who can, would it be possible for you to run Dolphin in debug mode in Android Studio to see where it crashes? If that's not something you can do, I can understand that, but if it's possible, it would help a lot with figuring out what the issue is.

#5 Updated by MrMrMANGOMILK 9 months ago

Unfortunately not; I haven't been able to get Android Studio running under Linux at all. Hopefully Windows will be better but I've never touched the program so I expect there will be a very steep learning curve.

#6 Updated by MrMrMANGOMILK 9 months ago

Reverted to the 5.0-11109 behavior as of 5.0-11201.

#7 Updated by MrMrMANGOMILK 4 months ago

I did some testing on this because I was bored, and it turns out this doesn't happen under OpenGL, but still does on Vulkan (version 5.0-11871, same device but now on Android 10 with One UI 2.0). The issue was likely always related to Vulkan, as I'd been using it under the assumption that it was faster across the board (not sure if that's true?). Hopefully this will help reproduce the issue on different hardware, I've vaguely heard about OpenGL being more popular on Android

#8 Updated by JosJuice 4 months ago

  • Is duplicate of Emulator Issues #12040: Dolphin Android crashes on savestate when using Vulkan (AbstractTextureFormat assert fails) added

#9 Updated by JosJuice 4 months ago

  • Status changed from New to Duplicate

Ah, right, this is the Vulkan savestate issue.

Also available in: Atom PDF