Project

General

Profile

Emulator Issues #11832

Software renderer shows old frame in frame in SMG

Added by Miksel12 over 1 year ago. Updated 7 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

SMG

Game ID? (right click the game in the game list, Properties, Info tab)

RMGE01

MD5 Hash? (right click the game in the game list, Properties, Verify tab, Verify Integrity button)

8eac1d25208b3413885007e61bd74665

What's the problem? Describe what went wrong.

During the boss roar of dino piranha (I was checking if https://bugs.dolphin-emu.org/issues/8327 still is a problem), the software renderer shows the current frame in the upper right corner.

What steps will reproduce the problem?

Watch the boss roar with software renderer enabled.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

5.0-10852

Is the issue present in the latest stable version?

Didn't test

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

-

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

See picture.

What are your PC specifications? (CPU, GPU, Operating System, more)

i5 4670K, GTX 1060, W10

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

RMGE01-1.png (270 KB) RMGE01-1.png Miksel12, 08/20/2019 11:05 PM
SMGBossSoftware.rar (1.48 MB) SMGBossSoftware.rar Miksel12, 08/29/2019 01:43 PM
7530

Related issues

Related to Emulator - Emulator Issues #9069: Super Mario Galaxy 2 - Motion Blur Effect missing during boss fights' screaming/roaring scenesDuplicate

Related to Emulator - Emulator Issues #8327: Super Mario Galaxy 1/2 - Roar shockwave does not displayAccepted

History

#1 Updated by Miksel12 over 1 year ago

I couldn't reproduce this issue in 5.0.

#2 Updated by Miksel12 over 1 year ago

Here is the Fifolog. The log shows that this issue is also present in the hardware backends and also in 5.0. Though the fifolog in 5.0 and in the latest dev build are different. I don't think it is coincidence that this happens during the missing shockwave effect.

#3 Updated by JMC4789 7 months ago

I don't think it's a coincidence either. Would you mind if I moved this information into the missing shockwave effect issue?

#4 Updated by Miksel12 7 months ago

No problem.

#5 Updated by JMC4789 7 months ago

  • Status changed from New to Duplicate

We probably want to move the attachments over or something too because they show that something interesting is going on.

#6 Updated by JMC4789 7 months ago

  • Related to Emulator Issues #9069: Super Mario Galaxy 2 - Motion Blur Effect missing during boss fights' screaming/roaring scenes added

#7 Updated by JMC4789 7 months ago

Also available in: Atom PDF